This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 435216 - F9 - ATI Driver - Text too large
F9 - ATI Driver - Text too large
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 467983
  Show dependency treegraph
 
Reported: 2008-02-27 19:00 EST by Gerald Cox
Modified: 2008-10-22 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 18:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg Log File as requested (37.09 KB, application/octet-stream)
2008-02-27 19:45 EST, Gerald Cox
no flags Details
Working with VESA driver (52.91 KB, application/octet-stream)
2008-02-29 20:00 EST, Gerald Cox
no flags Details
BLACK SCREEN with RADEON DRIVER (30.55 KB, application/octet-stream)
2008-02-29 20:01 EST, Gerald Cox
no flags Details
Xorg Log File showing Large Text after ati-6.8.0-3 (37.61 KB, application/octet-stream)
2008-03-03 20:56 EST, Gerald Cox
no flags Details
Xorg Log File showing Large Text ati-6.8.0-4 xorg 1.4.99.901-10 (40.46 KB, application/octet-stream)
2008-03-24 23:50 EDT, Gerald Cox
no flags Details
Xorg Log File showing Large Text (45.04 KB, application/octet-stream)
2008-03-27 10:43 EDT, Gerald Cox
no flags Details
Xorg Log File showing Large Text (40.83 KB, application/octet-stream)
2008-03-28 11:51 EDT, Gerald Cox
no flags Details
rayvd - xorg.conf w/ Radeon driver and randr config. (1.77 KB, text/plain)
2008-03-30 15:28 EDT, Ray Van Dolson
no flags Details
rayvd - Screenshot of phenomenon (278.64 KB, image/jpeg)
2008-03-30 15:30 EDT, Ray Van Dolson
no flags Details
rayvd - Xorg log in use with radeon driver exhibiting phenomenon. (67.99 KB, text/plain)
2008-03-30 15:31 EDT, Ray Van Dolson
no flags Details

  None (edit)
Description Gerald Cox 2008-02-27 19:00:37 EST
Description of problem:
Upgraded to xorg-x11-drv-ati-6.8.0-2.fc9.x86_64 as part of "yum update".  Now
all text fonts are ridiculously large and I'm barely able to enter text
commands.  I've tried to backout to xorg-x11-drv-ati-6.8.0-1.fc9.x86_64 but I
get a message saying it isn't available.


Version-Release number of selected component (if applicable):
See Description

How reproducible:
Boot the system, appears when normal text is displayed.  GUI appears normal, but
I'm unable to operate a console window or any window with text.


Steps to Reproduce:
1.  See above
2.
3.
  
Actual results:
Unusable.  Text too large to navigate.


Expected results:
Readable text.


Additional info:
Comment 1 Gerald Cox 2008-02-27 19:01:45 EST
You need to pull this update and restore the last version.  It didn't have 3D
but at least it was usable.
Comment 2 Dave Airlie 2008-02-27 19:11:36 EST
can you attach a log file please?

it sounds like either your DPI has always been wrong and is now right and you
compenstated for it by upping font sizes.

or we could just be detecting your monitor wrong.. I can't tell without a log file.
Comment 3 Gerald Cox 2008-02-27 19:45:18 EST
Created attachment 296144 [details]
Xorg Log File as requested

Was about to boot in single user, modified xorg.conf to use vesa driver instead
of radeon as a workaround.  KDE4 is completely hosed but able to get in via
gnome.	Please advise.
Comment 4 Dave Airlie 2008-02-27 20:03:39 EST
Image Size:  289 x 21 mm

your monitor EDID is make of failure..

the xserver has the database of workarounds, and I've just pushed a fix to the
X.org server, it'll hit rawhide on the next rebase.

the best workaround for now is to add a monitor section to your xorg.conf and
override the

Section "Monitor0"
     DisplaySize 289 210
EndSection

and in the driver section
Option "Monitor-LVDS" "Monitor0"




Comment 5 Gerald Cox 2008-02-28 11:38:37 EST
Thank you, the override in xorg.conf has circumvented the problem.  Can you
please let me know the name of the rpm for the fix so I can remove the xorg.conf
workaround when the revised rpm is applied to make sure it works.  I will report
the status in this ticket. 
Comment 6 Gerald Cox 2008-02-29 20:00:36 EST
Created attachment 296436 [details]
Working with VESA driver
Comment 7 Gerald Cox 2008-02-29 20:01:13 EST
Created attachment 296437 [details]
BLACK SCREEN with RADEON DRIVER
Comment 8 Gerald Cox 2008-02-29 22:26:39 EST
Applied: 

xorg-x11-server-Xorg-1.4.99.1-0.26.20080227.fc9
xorg-x11-server-common-1.4.99.1-0.26.20080227.fc9

Now screen becomes BLANK (BLACK) with no activity when X starts.  The only way I
was able to recover was to go back to using the VESA driver.  Looks like the
server updates broke something else rather than fixing the large print problem.
 I've attached two xorg.logs, one using the VESA driver, and the other was using
the radeon driver which results in a blank screen now.

I didn't have any of these problems before I applied:
xorg-x11-drv-ati-6.8.0-2.fc9.x86_64
Comment 9 Gerald Cox 2008-03-03 15:31:15 EST
Card in question is:  ATI Radeon XPRESS 200M 5955 (PCIE)
Comment 10 Matěj Cepl 2008-03-03 18:57:46 EST
Let's keep this bug about too large text, and let's return to it when your
display again. When Xserver will work again, would you please, report what
happened to the size of text?
Comment 11 Gerald Cox 2008-03-03 20:56:00 EST
Created attachment 296694 [details]
Xorg Log File showing Large Text after ati-6.8.0-3
Comment 12 Gerald Cox 2008-03-03 20:58:18 EST
Applied xorg-x11-drv-ati-6.8.0-3.fc9.x86_64
X now working again.

Removed the workaround to xorg.conf and the large text returned.  I have
attached the xorg.log - let me know if you require more information.  Thank you.
Comment 13 Gerald Cox 2008-03-10 22:36:35 EDT
Problem still exists with:

xorg-x11-drv-ati-6.8.0-3.fc9.x86_64
xorg-x11-server-common-1.4.99.901-1.20080307.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.x86_64
Comment 14 Gerald Cox 2008-03-13 10:20:14 EDT
Problem still exists with:

xorg-x11-server-common-1.4.99.901-5.20080310.fc9.x86_64
xorg-x11-server-utils-7.3-3.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-5.20080310.fc9.x86_64
xorg-x11-drv-ati-6.8.0-3.fc9.x86_64
Comment 15 Gerald Cox 2008-03-14 09:48:44 EDT
Problem still exists with:

xorg-x11-server-common-1.4.99.901-8.20080310.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-8.20080310.fc9.x86_64
Comment 16 Gerald Cox 2008-03-24 20:59:20 EDT
Problem still exists with:
xorg-x11-server-Xorg-1.4.99.901-10.20080314.fc9.x86_64
xorg-x11-server-common-1.4.99.901-10.20080314.fc9.x86_64
xorg-x11-drv-ati-6.8.0-4.fc9.x86_64
Comment 17 Dave Airlie 2008-03-24 22:40:44 EDT
can you attach a log from the latest codebases? and also the output from xrandr

Comment 18 Gerald Cox 2008-03-24 23:50:16 EDT
Created attachment 298971 [details]
Xorg Log File showing Large Text ati-6.8.0-4 xorg 1.4.99.901-10
Comment 19 Gerald Cox 2008-03-24 23:52:52 EDT
Output from xrandr - with xorg.conf workaround applied.  Cannot enter commands
when large text problem occurs.

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 289mm x 21mm
   1280x800       60.1*+   60.0
   1280x768       60.0
   1280x720       60.0
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)
Comment 20 Dave Airlie 2008-03-26 20:11:28 EDT
can you remove the workaround, wierdly we seem to be quirking the monitor but
xrandr is still returning the wrong answer... I'll try and dig out why...
Comment 21 Gerald Cox 2008-03-26 22:53:58 EDT
ok, here is the output from xrandr when the text is too large.  Let me know if
I can provide any additional information.  Thanks!

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 289mm x 21mm
   1280x800       60.1*+   60.0
   1280x768       60.0
   1280x720       60.0
   1024x768       60.0
   800x600        60.3
   640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)
Comment 22 Dave Airlie 2008-03-27 01:25:36 EDT
thanks for hanging on I think I found it finally..

please try server 1.4.99.901-12.20080314 from rawhide or koji when it lands.

Comment 23 Gerald Cox 2008-03-27 10:41:05 EDT
Same result, large text... here are the versions installed:

xorg-x11-drv-ati-6.8.0-5.fc9.x86_64
xorg-x11-server-utils-7.3-3.fc9.x86_64
xorg-x11-server-common-1.4.99.901-12.20080314.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-12.20080314.fc9.x86_64

xrandr during failure:

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 289mm x 21mm
   1280x800       60.1*+   60.0
   1280x768       60.0
   1280x720       60.0
   1024x768       60.0
   800x600        60.3
   640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)
Comment 24 Gerald Cox 2008-03-27 10:43:10 EDT
Created attachment 299333 [details]
Xorg Log File showing Large Text
Comment 25 Gerald Cox 2008-03-28 11:50:00 EDT
Applied the updates below... problem still exists...

xorg-x11-server-common-1.4.99.901-13.20080314.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-13.20080314.fc9.x86_64
xorg-x11-drv-ati-6.8.0-5.fc9.x86_64

xrandr output:

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 289mm x 21mm
   1280x800       60.1*+   60.0
   1280x768       60.0
   1280x720       60.0
   1024x768       60.0
   800x600        60.3
   640x480        59.9
S-video disconnected (normal left inverted right x axis y axis)

Comment 26 Gerald Cox 2008-03-28 11:51:48 EDT
Created attachment 299485 [details]
Xorg Log File showing Large Text
Comment 27 Ray Van Dolson 2008-03-30 15:24:45 EDT
I believe I am also experiencing this problem -- perhaps.  I only am seeing
issues with Firefox, but it goes away when I switch to the Vesa driver (although
the Vesa driver completely unuseable due to horrible performance).

I originally filed this bug against Firefox:

  https://bugzilla.redhat.com/show_bug.cgi?id=439616

But then I found this.  I will post my current xorg.conf, Xserver log and xrandr
output.  I tried the workaround mentioned above but it seems to have no affect.
 Oh, I'll also post a screenshot of the phenomenon.

HW details are as follows:
ASUS A7V333 Motherboard
ASUS Radeon 9800 (R350 chip with Vivo)
Fresh install of Fedora 9 Beta 3 updated with latest updates from rawhide.
Comment 28 Ray Van Dolson 2008-03-30 15:28:35 EDT
Created attachment 299634 [details]
rayvd - xorg.conf w/ Radeon driver and randr config.
Comment 29 Ray Van Dolson 2008-03-30 15:30:26 EDT
Created attachment 299635 [details]
rayvd - Screenshot of phenomenon
Comment 30 Ray Van Dolson 2008-03-30 15:31:26 EDT
Created attachment 299636 [details]
rayvd - Xorg log in use with radeon driver exhibiting phenomenon.
Comment 31 Ray Van Dolson 2008-03-30 15:34:35 EDT
In addition, I am using the following RPM versions:

xorg-x11-server-common-1.4.99.901-13.20080314.fc9.i386
xorg-x11-server-Xorg-1.4.99.901-13.20080314.fc9.i386
xorg-x11-drv-ati-6.8.0-6.fc9.i386

I am running at the default of 111 DPI, and have also tried at 96.
Comment 32 Dave Airlie 2008-03-31 00:14:23 EDT
Ray please log your own bug, I'm not able to track two issues like this in once
place.
Comment 33 Dave Airlie 2008-03-31 00:43:56 EDT
okay I'm just building ati driver 6.8.0-8.fc9.

http://koji.fedoraproject.org/packages/xorg-x11-drv-ati/6.8.0/8.fc9/

I've found yet another bug in its EDID quirk handling please let me know if it
helps. if it doesn't I'll be most unhappy, :)
Comment 34 Gerald Cox 2008-04-03 13:11:49 EDT
Sorry for the delay in responding...

Applied:
xorg-x11-drv-ati-6.8.0.9.fc9
xorg-x11-server-Xorg-1.4.99.901-16.20080401.fc9

Works!!!!!!!

Thank you very much for your help!  Glad we were able to resolve.


Comment 35 Gerald Cox 2008-04-03 13:13:23 EDT
sorry, to clarify:
xorg-x11-drv-ati-6.8.0-9.fc9 (had a little typo there)
Comment 36 Matěj Cepl 2008-10-22 19:06:42 EDT
*** Bug 466156 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.