Bug 468076 - HTS-5.2-16: USB ports not recognized on p6 570 system
HTS-5.2-16: USB ports not recognized on p6 570 system
Status: CLOSED DUPLICATE of bug 455762
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 13:07 EDT by IBM Bug Proxy
Modified: 2014-03-25 20:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 22:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 49193 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-10-22 13:07:59 EDT
HTS-5.2-16 doesn't recognize USB ports of the system.

HTS-5.2-20 fixed the above problems. But RedHat said HTS-5.2-20 is not an
official version. So they didn't accept the test results that I submitted, and
tell I have to use HTS-5.2-16.

lspci shows there are USB ports:

[root@chevy01 hts]# lspci
00:02.0 PCI bridge: IBM EADS-X PCI-X to PCI-X Bridge (rev 03)
00:02.4 PCI bridge: IBM EADS-X PCI-X to PCI-X Bridge (rev 03)
c0:01.0 RAID bus controller: IBM Obsidian chipset SCSI controller (rev 01)
d0:01.0 USB Controller: NEC Corporation USB (rev 43)
d0:01.1 USB Controller: NEC Corporation USB (rev 43)
d0:01.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0001:01:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet
Controller (rev 06)
0001:01:00.1 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet
Controller (rev 06)
[root@chevy01 hts]#

"hts print " shows no USB:

and contents of config.xml and plan.xml:

[root@chevy01 hts]# hts print

Test Plan:
----------------------------------------------------------------
cdrom      scd0
network    eth1
network    eth0
memory
core
storage    sda
storage    sdb
storage    sdc
info
-----------
[root@chevy01 hts]# cat config.xml
<?xml version='1.0' encoding='UTF-8'?>
<certification-test discover-time='2008-10-18 00:07:58' hts-release='16'
hts-version='5.2'>
  <hardware>
    <arch>ppc64</arch>
    <model>Power 570 Server (9117-MMA)</model>
    <vendor>IBM</vendor>
    <make/>
  </hardware>
  <certification>
    <os>
      <name>Nahant Update 5</name>
      <release>4</release>
    </os>
  </certification>
</certification-test>
-----------
[root@chevy01 hts]# cat plan.xml
<?xml version='1.0' encoding='UTF-8'?>
<certification-test discover-time='2008-10-18 00:07:58' plan-time='2008-10-18
00:07:59' hts-release='16' hts-version='5.2'>
  <hardware>
    <arch>ppc64</arch>
    <model>Power 570 Server (9117-MMA)</model>
    <vendor>IBM</vendor>
    <make/>
  </hardware>
  <certification>
    <os>
      <name>Nahant Update 5</name>
      <release>4</release>
    </os>
  </certification>
  <test name='cdrom' label='' logical-device='scd0' device-class='CDROM'
device-bus='SCSI' udi='' interactive='yes'/>
  <test name='network' label='' logical-device='eth1' device-class='NETWORK'
device-bus='PCI' udi='' interactive='no'/>
  <test name='network' label='' logical-device='eth0' device-class='NETWORK'
device-bus='PCI' udi='' interactive='no'/>
  <test name='memory' label='' logical-device='' device-class='MEMORY'
device-bus='' udi='' interactive='no'/>
  <test name='core' label='' logical-device='' device-class='CPU' device-bus=''
udi='' interactive='no'/>
  <test name='storage' label='' logical-device='sda' device-class='STORAGE'
device-bus='SCSI' udi='' interactive='no'/>
  <test name='storage' label='' logical-device='sdb' device-class='STORAGE'
device-bus='SCSI' udi='' interactive='no'/>
  <test name='storage' label='' logical-device='sdc' device-class='STORAGE'
device-bus='SCSI' udi='' interactive='no'/>
  <test name='info' label='' logical-device='' device-class='ALL' device-bus=''
udi='' interactive='no'/>
</certification-test>
----------------
Comment 1 YangKun 2008-10-22 22:09:21 EDT
Your operating system is RHEL4 --> "Nahant Update 5" .

"hts-5.2-16 can not add the USB test on RHEL4" is a known bug and was already fixed, please refer to https://bugzilla.redhat.com/show_bug.cgi?id=455762

This issue only applies to RHEL4. Meaning only the "RHEL4 USB testing" should utilize hts-5.2-20.

hts-5.2-16 can plan the USB test correctly on RHEL5. Since hts-5.2-20 is a preview release, so all USB testing on RHEL5 should be done with hts-5.2-16 .
Comment 2 YangKun 2008-10-22 22:10:33 EDT
closing this bug as duplicate with bug#455762

*** This bug has been marked as a duplicate of bug 455762 ***
Comment 3 IBM Bug Proxy 2008-10-24 08:39:29 EDT
test. please ignore.

Note You need to log in before you can comment on or make changes to this bug.