Bug 468113 - 802.1X authentication intermittant and get (nm-applet:3373): WARNING **: Unhandled setting secret type (write) '802-1x/private-key' : 'GArray_guchar_'
802.1X authentication intermittant and get (nm-applet:3373): WARNING **: Unha...
Status: CLOSED DUPLICATE of bug 497609
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-22 17:52 EDT by Tom London
Modified: 2009-05-09 22:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 22:59:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snippet of messages from /var/log/messages with the above (7.27 KB, text/plain)
2008-10-22 17:54 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-10-22 17:52:23 EDT
Description of problem:
NM correctly associates only intermittantly (like 1 in 4 or 5 attempts) with an 802.1X wireless network.

When this occurs, I see this in .xsession-errors:

** (nm-applet:3373): WARNING **: Unhandled setting secret type (write) '802-1x/phase2-private-key' : 'GArray_guchar_'

** (nm-applet:3373): WARNING **: Unhandled setting secret type (write) '802-1x/private-key' : 'GArray_guchar_'

** (nm-applet:3373): WARNING **: Unhandled setting secret type (write) '802-1x/phase2-private-key' : 'GArray_guchar_'

** (nm-applet:3373): WARNING **: _nm_object_get_property: Error getting 'Default' for /org/freedesktop/NetworkManager/ActiveConnection/1: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist


** Message: <info>  New secrets for Auto insidex/802-1x requested; ask the user


** (nm-applet:3373): WARNING **: Unhandled setting secret type (write) '802-1x/private-key' : 'GArray_guchar_'

** (nm-applet:3373): WARNING **: Unhandled setting secret type (write) '802-1x/phase2-private-key' : 'GArray_guchar_'
** Message: <info>  New secrets for Auto insidex/802-1x requested; ask the user


** (nm-applet:3373): WARNING **: applet-device-wifi.c.1512 (get_secrets_dialog_response_cb): canceled



Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.7.0-0.11.svn4175.fc10.x86_64
NetworkManager-openvpn-0.7.0-16.svn4175.fc10.x86_64
NetworkManager-glib-0.7.0-0.11.svn4201.fc10.x86_64
NetworkManager-0.7.0-0.11.svn4201.fc10.x86_64
NetworkManager-gnome-0.7.0-0.11.svn4201.fc10.x86_64


How reproducible:
Almost every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-10-22 17:54:41 EDT
Created attachment 321213 [details]
snippet of messages from /var/log/messages with the above
Comment 2 Bug Zapper 2008-11-25 23:08:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Tom London 2009-01-12 17:55:39 EST
I'm now running rawhide:

NetworkManager-openvpn-0.7.0-18.svn11.fc11.x86_64
NetworkManager-gnome-0.7.0-1.git20090102.fc11.x86_64
NetworkManager-pptp-0.7.0-1.svn16.fc11.x86_64
NetworkManager-vpnc-0.7.0-1.svn13.fc11.x86_64
NetworkManager-glib-0.7.0-1.git20090102.fc11.x86_64
NetworkManager-0.7.0-1.git20090102.fc11.x86_64

and this issue is much better.

Not perfect: I sometimes get authentication failure/request for password popup, probably 1 in 3-5 times.
Comment 4 Dan Williams 2009-04-08 21:29:14 EDT
*** Bug 493089 has been marked as a duplicate of this bug. ***
Comment 5 Niels Haase 2009-04-10 18:47:22 EDT
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Dan Williams 2009-05-09 22:59:38 EDT

*** This bug has been marked as a duplicate of bug 497609 ***

Note You need to log in before you can comment on or make changes to this bug.