Bug 493089 - nm-applet reports warning: "Unhandled setting secret type (write) 'vpn/secrets' : 'GHashTable_ gchararray+gchararray_'"
nm-applet reports warning: "Unhandled setting secret type (write) 'vpn/secret...
Status: CLOSED DUPLICATE of bug 497609
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 11:34 EDT by Tomislav Vujec
Modified: 2009-05-09 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 23:01:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix warning. (1.25 KB, patch)
2009-03-31 11:35 EDT, Tomislav Vujec
no flags Details | Diff

  None (edit)
Description Tomislav Vujec 2009-03-31 11:34:23 EDT
Description of problem:
nm-applet reports warning "Unhandled setting secret type (write) 'vpn/secrets' : 'GHashTable_ gchararray+gchararray_' " for vpn secrets which are handled by the VPN plugin. 

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.99

Additional info:
Either check if the secret is of the type vpn before the more general string type check, or do not warn when checking for string type. Latter could be more dangerous. Patch for the former is in the attachment.
Comment 1 Tomislav Vujec 2009-03-31 11:35:10 EDT
Created attachment 337321 [details]
Fix warning.
Comment 2 Dan Williams 2009-04-08 21:29:14 EDT

*** This bug has been marked as a duplicate of bug 468113 ***
Comment 3 Tomislav Vujec 2009-04-09 00:01:22 EDT
Hmmm, are you sure? The warning I am getting seems to be non-issue, since the VPN plugin handles the keyring storage of 'vpn/secrets'. The comment to the code that checks for that type seems to claim so. I just reordered the checks so that it is actually reached, which in turn disables the warning.
Comment 4 Dan Williams 2009-05-09 23:01:28 EDT

*** This bug has been marked as a duplicate of bug 497609 ***

Note You need to log in before you can comment on or make changes to this bug.