Bug 468180 - Upgrade of proxy do not work if you fail to run rhn_check after deactivating proxy with remove package option selected.
Upgrade of proxy do not work if you fail to run rhn_check after deactivating...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
: Reopened
Depends On:
Blocks: 456999 481168
  Show dependency treegraph
 
Reported: 2008-10-23 09:47 EDT by Preethi Thomas
Modified: 2009-09-10 10:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 481167 481168 (view as bug list)
Environment:
Last Closed: 2009-09-10 10:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-10-23 09:47:30 EDT
Description of problem:
When you have some conflicting packages on machine  the installer will
fail. 

Version-Release number of selected component (if applicable):
520

Steps to Reproduce:
1. install proxy 
2. deactivate (select remove packages)
4. Do not run rhn_check
3. install again using webui
  
Actual results:

D: Sending back response (1, 'Script failed', {'output': 'cnBtOiBubyBwYWNrYWdlcyBnaXZlbiBmb3IgZXJhc2UK\n', 'base64enc': 1, 'process_end': '2008-10-23 09:34:48', 'return_code': 256, 'process_start': '2008-10-23 09:34:38'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)


Expected results:
no error

More Info

If you try to activate the proxy again after the failing, it successfully completes.


Fails to install proxy
Run as: root:root
Timeout: 600 seconds

#!/bin/sh
rpm -e `for package in ConfigPusher-general eventReceivers httpd-suexec jabberd libapreq2 MessageQueue mod_perl NOCpulsePlugins NPalert np-config NPusers nslogs oracle_perl perl-Apache-Admin-Config perl-BerkeleyDB perl-BSD-Resource perl-Class-MethodMaker perl-Class-Singleton perl-Config-IniFiles perl-Crypt-DES perl-Crypt-GeneratePassword perl-DateTime perl-DateTime-Locale perl-DateTime-TimeZone perl-DBD-Oracle perl-Error perl-FreezeThaw perl-HTML-TableExtract perl-IO-Capture perl-IO-Socket-SSL perl-IO-stringy perl-libapreq2 perl-MailTools perl-MIME-tools perl-Net-SNMP perl-Net_SSLeay perl-Network-IPv4Addr perl-NOCpulse-CLAC perl-NOCpulse-Debug perl-NOCpulse-Gritch perl-NOCpulse-Object perl-NOCpulse-OracleDB perl-NOCpulse-PersistentConnection perl-NOCpulse-Probe perl-NOCpulse-ProcessPool perl-NOCpulse-Scheduler perl-NOCpulse-SetID perl-NOCpulse-Utils perl-Params-Validate perl-TimeDate perl-XML-Generator ProgAGoGo python-sgmlop rhn-base-minimal rhns rhns-certs-tools rhns-proxy-broker rhns-proxy-docs rhns-proxy-management rhns-proxy-monitoring rhns-proxy-package-manager rhns-proxy-redirect rhns-proxy-tools rhn-ssl-cert-check SatConfig-bootstrap SatConfig-bootstrap-server SatConfig-cluster SatConfig-dbsynch SatConfig-general SatConfig-generator SatConfig-installer SatConfig-spread scdb SNMPAlerts SputLite-client SputLite-server ssl_bridge status_log_acceptor tsdb; do
rpm -q $package >/dev/null && echo $package; done`


Start Date: 2008-10-23 09:07:48
End Date: 2008-10-23 09:07:54
Return Code: 256
Raw Output: view/download raw script output
Filtered Output:

rpm: no packages given for erase
Comment 1 Miroslav Suchý 2008-10-23 10:01:22 EDT
This happens in 5.1 as well. Sat5.2.0 is only RHEL5 and Oracle 10g and regression. Since this is not regression, I'm not going to fix in sat 5.2

And since in 5.3 will be WebUI installer replaced with CLI installer and WEBUI installer will be in maintance, and since this bug has very low impact and is *very* hard to fix... I'm setting the bug WONTFIX.
Comment 2 Preethi Thomas 2008-10-27 14:22:42 EDT
I think this needs to be documented. May be displaying a message to run rhn_check after deactivating the satellite should work.  reopening and aligning to sat 5.3 triage.
Comment 3 Brandon Perkins 2008-10-30 11:44:39 EDT
Cliff and I agree with both Comment #1 and Comment #2.  We suggest to have a simple solution, let's just put up a blue dialog after deactivate proxy that says something along the lines of: "Proxy deactivation scheduled, please run rhn_check on the proxy server to complete this process."

I don't think we want to add more logic to the WebUI activation as we are deprecating it.
Comment 4 Miroslav Suchý 2009-01-22 10:23:55 EST
Fixed in Spacewalk BZ 481167.
Comment 5 Miroslav Suchý 2009-01-28 05:25:23 EST
Mass moving to ON_QA.
Comment 9 Brandon Perkins 2009-09-10 10:36:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.