Bug 481168 - Upgrade of proxy do not work if you fail to run rhn_check after deactivating proxy with remove package option selected.
Upgrade of proxy do not work if you fail to run rhn_check after deactivating...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
us=72943
:
Depends On: 468180
Blocks: rhn-512
  Show dependency treegraph
 
Reported: 2009-01-22 10:27 EST by Miroslav Suchý
Modified: 2013-01-10 04:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 468180
Environment:
Last Closed: 2009-08-10 09:02:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-01-22 10:27:46 EST
+++ This bug was initially created as a clone of Bug #468180 +++

Description of problem:
When you have some conflicting packages on machine  the installer will
fail. 

Version-Release number of selected component (if applicable):
520

Steps to Reproduce:
1. install proxy 
2. deactivate (select remove packages)
4. Do not run rhn_check
3. install again using webui
  
Actual results:

D: Sending back response (1, 'Script failed', {'output': 'cnBtOiBubyBwYWNrYWdlcyBnaXZlbiBmb3IgZXJhc2UK\n', 'base64enc': 1, 'process_end': '2008-10-23 09:34:48', 'return_code': 256, 'process_start': '2008-10-23 09:34:38'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)


Expected results:
no error

More Info

If you try to activate the proxy again after the failing, it successfully completes.


Fails to install proxy
Run as: root:root
Timeout: 600 seconds

#!/bin/sh
rpm -e `for package in ConfigPusher-general eventReceivers httpd-suexec jabberd libapreq2 MessageQueue mod_perl NOCpulsePlugins NPalert np-config NPusers nslogs oracle_perl perl-Apache-Admin-Config perl-BerkeleyDB perl-BSD-Resource perl-Class-MethodMaker perl-Class-Singleton perl-Config-IniFiles perl-Crypt-DES perl-Crypt-GeneratePassword perl-DateTime perl-DateTime-Locale perl-DateTime-TimeZone perl-DBD-Oracle perl-Error perl-FreezeThaw perl-HTML-TableExtract perl-IO-Capture perl-IO-Socket-SSL perl-IO-stringy perl-libapreq2 perl-MailTools perl-MIME-tools perl-Net-SNMP perl-Net_SSLeay perl-Network-IPv4Addr perl-NOCpulse-CLAC perl-NOCpulse-Debug perl-NOCpulse-Gritch perl-NOCpulse-Object perl-NOCpulse-OracleDB perl-NOCpulse-PersistentConnection perl-NOCpulse-Probe perl-NOCpulse-ProcessPool perl-NOCpulse-Scheduler perl-NOCpulse-SetID perl-NOCpulse-Utils perl-Params-Validate perl-TimeDate perl-XML-Generator ProgAGoGo python-sgmlop rhn-base-minimal rhns rhns-certs-tools rhns-proxy-broker rhns-proxy-docs rhns-proxy-management rhns-proxy-monitoring rhns-proxy-package-manager rhns-proxy-redirect rhns-proxy-tools rhn-ssl-cert-check SatConfig-bootstrap SatConfig-bootstrap-server SatConfig-cluster SatConfig-dbsynch SatConfig-general SatConfig-generator SatConfig-installer SatConfig-spread scdb SNMPAlerts SputLite-client SputLite-server ssl_bridge status_log_acceptor tsdb; do
rpm -q $package >/dev/null && echo $package; done`


Start Date: 2008-10-23 09:07:48
End Date: 2008-10-23 09:07:54
Return Code: 256
Raw Output: view/download raw script output
Filtered Output:

rpm: no packages given for erase

--- Additional comment from msuchy@redhat.com on 2008-10-23 10:01:22 EDT ---

This happens in 5.1 as well. Sat5.2.0 is only RHEL5 and Oracle 10g and regression. Since this is not regression, I'm not going to fix in sat 5.2

And since in 5.3 will be WebUI installer replaced with CLI installer and WEBUI installer will be in maintance, and since this bug has very low impact and is *very* hard to fix... I'm setting the bug WONTFIX.

--- Additional comment from pthomas@redhat.com on 2008-10-27 14:22:42 EDT ---

I think this needs to be documented. May be displaying a message to run rhn_check after deactivating the satellite should work.  reopening and aligning to sat 5.3 triage.

--- Additional comment from bperkins@redhat.com on 2008-10-30 11:44:39 EDT ---

Cliff and I agree with both Comment #1 and Comment #2.  We suggest to have a simple solution, let's just put up a blue dialog after deactivate proxy that says something along the lines of: "Proxy deactivation scheduled, please run rhn_check on the proxy server to complete this process."

I don't think we want to add more logic to the WebUI activation as we are deprecating it.

--- Additional comment from msuchy@redhat.com on 2009-01-22 10:23:55 EDT ---

Fixed in Spacewalk BZ 481167.
Comment 1 Miroslav Suchý 2009-01-22 10:29:00 EST
Please pick up the changes from:
http://git.fedorahosted.org/git/?p=spacewalk.git;a=commitdiff;h=c2a11cb3db6ef2b051f70100487edf9a98bd36f2
Comment 2 Stephen Herr 2009-07-24 09:58:13 EDT
verified on dev
Comment 3 Stephen Herr 2009-07-31 16:45:27 EDT
Could not verify in qa because of broken rpms on the filer. We do most of our testing in dev, and the qa check is really only to verify that the push was successful anyway.

Note You need to log in before you can comment on or make changes to this bug.