Bug 468369 - X (gdm) is dead on boot (radeon)
X (gdm) is dead on boot (radeon)
Status: CLOSED DUPLICATE of bug 468294
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-24 08:36 EDT by Pete Zaitcev
Modified: 2008-10-25 12:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 12:59:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Good dmesg (30.95 KB, text/plain)
2008-10-24 08:50 EDT, Pete Zaitcev
no flags Details
Good Xorg.0.log (101.71 KB, text/plain)
2008-10-24 08:51 EDT, Pete Zaitcev
no flags Details
dmesg (31.56 KB, text/plain)
2008-10-24 08:52 EDT, Pete Zaitcev
no flags Details
Xorg.0.log (36.70 KB, text/plain)
2008-10-24 08:53 EDT, Pete Zaitcev
no flags Details
strace of X (727 bytes, text/plain)
2008-10-24 08:55 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2008-10-24 08:36:00 EDT
Description of problem:

On reboot, blank screen and dead keyboard when X starts up.

Version-Release number of selected component (if applicable):

2.6.27.3-39.fc10

How reproducible:

100% on given hardware

Steps to Reproduce:
1. Reboot
  
Actual results:

X is dead

Expected results:

Login screen

Additional info:

The system does not lock up: it reacts to the power button.
I'm working on getting the debugging information out of it.

This system is running with nomodeset.

Last known good kernel is 2.6.27.3-30.rc1.fc10.
Comment 1 Pete Zaitcev 2008-10-24 08:50:45 EDT
Created attachment 321404 [details]
Good dmesg
Comment 2 Pete Zaitcev 2008-10-24 08:51:28 EDT
Created attachment 321405 [details]
Good Xorg.0.log
Comment 3 Pete Zaitcev 2008-10-24 08:52:10 EDT
Created attachment 321406 [details]
dmesg
Comment 4 Pete Zaitcev 2008-10-24 08:53:29 EDT
Created attachment 321407 [details]
Xorg.0.log
Comment 5 Pete Zaitcev 2008-10-24 08:55:27 EDT
Created attachment 321408 [details]
strace of X

X loops over ioctl 0x6444 (probably /dev/dri/card0).
Comment 6 Gerald Cox 2008-10-25 00:47:46 EDT
This looks the same as 468294.
Comment 7 Pete Zaitcev 2008-10-25 12:59:09 EDT
Yes, it looks the same, although my box locks up without nomodeset,
so I cannot see the whitescreen. I'm duping this now. Thanks, Gerald.

*** This bug has been marked as a duplicate of bug 468294 ***

Note You need to log in before you can comment on or make changes to this bug.