Bug 468294 - F10 Blackscreen with cursor then whitescreen after kernel update
F10 Blackscreen with cursor then whitescreen after kernel update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 468334 468369 468505 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 18:21 EDT by Gerald Cox
Modified: 2008-10-28 21:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 21:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of dmesg of system, before X started (26.24 KB, text/plain)
2008-10-23 18:59 EDT, Gerald Cox
no flags Details
Xorg.0.log when whitescreen occurs (66.98 KB, text/plain)
2008-10-23 19:00 EDT, Gerald Cox
no flags Details
Xorg.0.log when blackscreen occurs (32.98 KB, text/plain)
2008-10-23 19:00 EDT, Gerald Cox
no flags Details
dmesg with kernel 2.6.27.3-44 (26.29 KB, application/octet-stream)
2008-10-25 11:43 EDT, Gerald Cox
no flags Details
Xorg.0.log with kernel 2.6.27.3-44 (33.01 KB, application/octet-stream)
2008-10-25 11:45 EDT, Gerald Cox
no flags Details
xorg.conf being used due to bug 467983 (562 bytes, application/octet-stream)
2008-10-25 11:47 EDT, Gerald Cox
no flags Details

  None (edit)
Description Gerald Cox 2008-10-23 18:21:56 EDT
Description of problem:
After application of 2.6.27.3-34.rc1.fc10.x86_64 and 
2.6.27.39.fc10.x86_64 receive a whitescreen instead of logon screen when 
booting.  When I specify "nomodeset" I receive a black screen.
Workaround is to boot with kernel 2.6.27.3-30.rc1.fc10.x86_64


Version-Release number of selected component (if applicable):
Kernel:  2.6.27.39.fc10

How reproducible:
Normal boot


Steps to Reproduce:
1. Boot system
2.
3.
  
Actual results:
No special boot parameters receive:  White Screen
"nomodeset" receive:  Black Screen

Expected results:
Receive login screen.

Additional info:
Comment 1 Gerald Cox 2008-10-23 18:59:28 EDT
Created attachment 321353 [details]
results of dmesg of system, before X started
Comment 2 Gerald Cox 2008-10-23 19:00:19 EDT
Created attachment 321354 [details]
Xorg.0.log when whitescreen occurs
Comment 3 Gerald Cox 2008-10-23 19:00:55 EDT
Created attachment 321355 [details]
Xorg.0.log when blackscreen occurs
Comment 4 Gerald Cox 2008-10-25 00:40:05 EDT
*** Bug 468334 has been marked as a duplicate of this bug. ***
Comment 5 Gerald Cox 2008-10-25 00:50:06 EDT
This looks the same as 468369.
Comment 6 Gerald Cox 2008-10-25 11:41:24 EDT
Applied:

kernel-2.6.27.3-44.fc10.x86_64

Problem still exists.  Attaching new dmesg and Xorg.0.log.

Also, found that what is occurring without "nomodeset" parameter is:

1.  Black screen with cursor blinking in upper left hand corner of screen
2.  Then white screen with some "sparkles" appears
3.  Then hang
4.  Pressing power button without holding it down signals normal system shutdown

Workaround is kernel 2.6.27.3-30.rc1.fc10.x86_64
Comment 7 Gerald Cox 2008-10-25 11:43:49 EDT
Created attachment 321508 [details]
dmesg with kernel 2.6.27.3-44
Comment 8 Gerald Cox 2008-10-25 11:45:41 EDT
Created attachment 321509 [details]
Xorg.0.log with kernel 2.6.27.3-44
Comment 9 Gerald Cox 2008-10-25 11:47:14 EDT
Created attachment 321510 [details]
xorg.conf being used due to bug 467983
Comment 10 Gerald Cox 2008-10-25 11:48:12 EDT
For clarity purposes, problem also occurs when "nomodeset" is specified.
Comment 11 Pete Zaitcev 2008-10-25 12:59:09 EDT
*** Bug 468369 has been marked as a duplicate of this bug. ***
Comment 12 Gerwin Krist 2008-10-26 07:49:32 EDT
Same problem here, seems only to happen with ATI gpu's. I have some other symptons actually:

normal:
- if plymouth is loaded (no bar comes up), my monitor starts blinking and nothing happens

with nomodeset:
- I see the plymouth bar running till end .... nothing happens

Really nasty, anyone knows where to find "old" working kernels, forced to use a fc9 kernel now ...
Comment 13 Jeff Layton 2008-10-26 10:47:08 EDT
I'm having similar problems...

You can get older kernels from koji:

http://koji.fedoraproject.org/koji/packageinfo?packageID=8
Comment 14 Jeff Layton 2008-10-26 10:49:52 EDT
*** Bug 468505 has been marked as a duplicate of this bug. ***
Comment 15 Jeff Layton 2008-10-26 10:55:54 EDT
My symptoms are similar. When X starts, I get a "garbage pattern" with horizontal lines on the screen (maybe the result of uninit'ed video RAM?). If I boot with nomodeset, I also get a black screen when X starts. My video chip is:

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 30ae
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 66 (2000ns min), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 17
	Region 0: Memory at c8000000 (32-bit, prefetchable) [size=128M]
	Region 1: I/O ports at 9000 [size=256]
	Region 2: Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at c0120000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel modules: radeonfb, radeon

Let me know if you need other info. While I haven't tried it, the machine seems to be responsive when it's in this state. It's just the display that's problematic. I can probably set it up so that I can ssh into the laptop when it's in this state and collect other info if it'll be helpful.
Comment 16 Gerald Cox 2008-10-26 19:45:31 EDT
Applied:  kernel-2.6.27.4-47.rc3.fc10.x86_64
Problem still exists.  No change.

Workaround continues to be:  kernel-2.6.27.3-30.rc1.fc10.x86_64
Comment 17 Gerald Cox 2008-10-27 19:25:53 EDT
Applied:  kernel-2.6.27.4-51.fc10.x86_64
Problem still exists.  No change.

Workaround continues to be:  kernel-2.6.27.3-30.rc1.fc10.x86_64
Comment 18 Gerald Cox 2008-10-28 21:59:34 EDT
Applied:  kernel-2.6.27.4-58.fc10.x86_64
Problem resolved.  Closing.

Nice razzle/dazzle startup eye-candy btw... ;-)

Note You need to log in before you can comment on or make changes to this bug.