Bug 468380 - backport /proc/<pid>/limits feature
backport /proc/<pid>/limits feature
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
medium Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
: FutureFeature, OtherQA
Depends On:
Blocks: 460679 468381
  Show dependency treegraph
 
Reported: 2008-10-24 09:54 EDT by Helge Deller
Modified: 2009-06-20 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 03:21:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2008-10-24 09:54:33 EDT
Feature request based on the discussions from bug 461946:

Linux upstream kernels have the feature that makes it possible to see resource limits of a running process via "cat /proc/<pid>/limits".
Please backport this feature to the RHEL5 kernel.
Comment 1 Jiri Pirko 2008-10-25 09:41:51 EDT
Helge, what do you exactly need to be backported? As I tested it with 2.6.18-92.el5 I can see resource limits via "cat /proc/<pid>/limits" (unlike rhel4). Thanks.
Comment 2 Linda Wang 2008-10-25 13:31:59 EDT
please take a look at bug 253762, kernel version 2.6.18-60.el5+
in 5.2 GA. Because this feature has already been backported to 253762.
Please let us know if 5.2's implementation does not meet your needs.

thanks.
Comment 3 Hannes Kuehnemund 2008-10-27 02:00:23 EDT
Sorry, the short description of bug 461946 was not complete. It should also state, that it should be possible to change the limits during runtime. As an example, "Core file size" is usually set to "0" (no core is written), but you for debugging purposes you have to change this for a certain binary to write a core file w/o restarting it. Therefore, it should also be possible to change the limits of a process during runtime.
Comment 4 Hannes Kuehnemund 2008-10-27 05:25:54 EDT
Ok, misunderstanding from our side. Showing limits is fine in the first place. You can close this BZ, thx
Comment 5 Jiri Pirko 2008-10-29 03:21:02 EDT
Ok. Thanks Hannes. Closing the bug.
Comment 6 Helge Deller 2008-10-29 06:19:41 EDT
Closed as "currentrelease", instead of "not a bug", since it was already backported into RHEL 5.2 and it was not in RHEL 5.0.

Note You need to log in before you can comment on or make changes to this bug.