Bug 468478 - Unable to shrink LVM LV
Unable to shrink LVM LV
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-10-24 19:35 EDT by Jesse Keating
Modified: 2013-01-09 22:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 18:13:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error. (29.26 KB, image/png)
2008-10-24 19:35 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2008-10-24 19:35:28 EDT
Created attachment 321481 [details]
screenshot of error.

I've got a LVM VG with a couple LVs in it.  I attempted an install where I shrank one of the LVs down quite a bit.  The installer failed to resize the volume and just gave me an option to exit the installer.

I'll attach a screenshot.
Comment 1 David Cantrell 2008-10-24 21:01:21 EDT
What was the disk layout on the system you were installing to?  I want to try to recreate it here.
Comment 2 Hans de Goede 2008-10-25 04:17:07 EDT
Jesse,

I see that yo've alreayd figured out the likely cause and created a new bug for that, closing this one as a dup of that one.

*** This bug has been marked as a duplicate of bug 468479 ***
Comment 3 Jesse Keating 2008-10-25 12:44:10 EDT
Actually the other bug I opened was different.  The other bug the resize was successful but extra output made anaconda think it failed.  In this bug, the resize just plain was not successful.

To answer David, the system in question is a dmraid system with two 74gig SATA drives in a dm stripe.  There was a 200 meg /boot partition, then the rest is an LVM PV.  That PV is used for a VG, and within the VG there was a 2048 meg swap LV, and then the rest was a LV for /.  It's this / LV that I'm trying to shrink.  (note, this is basically the layout  you get if you let anaconda auto partition the first time.

I do think I know what caused this though in retrospect, I clicked both resize /and/ format which I think led to the problem.  I need to re-test with and without clicking format to see if that makes a difference.
Comment 4 Jeremy Katz 2008-10-26 12:48:27 EDT
lvresize seems to require a --force now or its interactive.  Added --force in git
Comment 5 Jesse Keating 2008-10-30 18:13:47 EDT
That fixes it.

Note You need to log in before you can comment on or make changes to this bug.