Bug 468479 - Extra output seems to confuse resizing in anaconda
Extra output seems to confuse resizing in anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-10-24 20:07 EDT by Jesse Keating
Modified: 2013-01-09 22:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 18:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-10-24 20:07:57 EDT
When attempting to resize an LVM LV (shrink it down) I got this error screen.  Unfortunately it's a live install and I don't think it's logged anywhere.

Running... ['resize2fs', '-p', '/dev/VolGroup01/LogVol00', '27344M']
Resizing the filesystem on /dev/VolGroup01/LogVol00 to 7000064 (4k) blocks.
Begin pass 3 (max = 292)
Scanning inode table          ----------------------------------------XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
The filesystem on /dev/VolGroup01/LogVol00 is now 7000064 blocks long.



Anaconda thinks the resize failed.
Comment 1 Hans de Goede 2008-10-25 04:17:07 EDT
*** Bug 468478 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2008-10-26 12:43:56 EDT
The output isn't the problem -- we say it failed based on the exit status being non-zero.  I'm not seeing any cases of a successful resize returning zero from a quick look through the resize2fs code.  Eric -- any thoughts?

(Also, adjusted the error so that it will at least tell us what was returned)
Comment 3 Eric Sandeen 2008-10-26 21:50:05 EDT
After the message above, in resize's main():

        printf(_("The filesystem on %s is now %u blocks long.\n\n"),
               device_name, new_size);

the only possible return is (0), and I don't see any called functions between the two points which could lead to an exit().

So I don't get why it thinks it failed...?  I guess it'll be interesting to see the error code ...
Comment 4 Jesse Keating 2008-10-30 18:13:30 EDT
I can't duplicate this anymore :/

Note You need to log in before you can comment on or make changes to this bug.