Bug 468490 - Liveconnect java plugin fails to load class (webct)
Liveconnect java plugin fails to load class (webct)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
http://elearning.agsm.edu.au/
:
: 469098 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 03:14 EDT by Bradley
Modified: 2009-02-24 14:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 14:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log (10.09 KB, text/plain)
2008-10-25 03:18 EDT, Bradley
no flags Details
java.stderr (6.41 KB, text/plain)
2008-10-25 03:18 EDT, Bradley
no flags Details
java.stdout (352 bytes, text/plain)
2008-10-25 03:19 EDT, Bradley
no flags Details

  None (edit)
Description Bradley 2008-10-25 03:14:39 EDT
Description of problem:

The new liveconnect plugin crashes on http://elearning.agsm.edu.au

Version-Release number of selected component (if applicable):

java-1.6.0-openjdk-1.6.0.0-1.1.b12.fc10.x86_64
xulrunner-1.9.0.2-1.fc9.x86_64
firefox-3.0.2-1.fc9.x86_64

NB - **I'm testing this on F9, not rawhide**. I get the same result if I take the srpm from koji and rebuild it myself.

How reproducible: Always

Steps to Reproduce:
1. go to http://elearning.agsm.edu.au/
2. Allow the popup
  
Actual results:

Popup/java tester window opens, then browser crashes

Expected results:

Not crash. Popup should auto-close

Additional info:

The 'standard' F9 gcjwebplugin would open the popup window, but not close it. It closes on winxp, so I assume that theres something that is meant to close the extra window if the java version test passes.

ICEDTEAPLUGIN_DEBUG=1 firefox -g

log is attached.
Comment 1 Bradley 2008-10-25 03:18:28 EDT
Created attachment 321489 [details]
Log
Comment 2 Bradley 2008-10-25 03:18:55 EDT
Created attachment 321490 [details]
java.stderr
Comment 3 Bradley 2008-10-25 03:19:17 EDT
Created attachment 321491 [details]
java.stdout
Comment 4 Bradley 2008-10-25 04:01:58 EDT
Poking arround with this a bit, it looks like the reason that its failing to load is because the applet has:

<param name="cache_archive_ex" value="browserchecker_applet.jar;preload;1190988167141">

which doesn't see to be understood. So thats one problem (thats not new, but I was hoping that it was fixed with the new liveconnect stuff), but the plugin still shouldn't crash.

The plugin under linux tries to load /webct/jar/com/webct/platform/tools/browserchecker/applet/BrowserCheckerApplet.class while Sun java on windows loads /webct/jar/browserchecker_applet.jar

Some notes:
 - once the test has part it won't try again without restarting the browser; presumably theres a session cookie being set
 - The applet param means that java caches the applet, so you won't see the network request for it again unless you clear the cache via the java control panel on windows
Comment 5 Bradley 2008-10-25 04:17:13 EDT
... and now it doesn't crash for me, even though I didn't change anything. Still doesn't work, though.
Comment 6 Deepak Bhole 2008-11-14 15:44:51 EST
Yes, cache_archive_ex is still unsupported unfortunately. It is on my list though, and I plan to start work on it shortly. Corresponding upstream bug:

http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=233
Comment 7 Deepak Bhole 2008-11-14 15:58:21 EST
*** Bug 469098 has been marked as a duplicate of this bug. ***
Comment 8 Bug Zapper 2008-11-25 23:13:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Deepak Bhole 2009-02-24 14:13:06 EST
Should be fixed in the latest release.

Note You need to log in before you can comment on or make changes to this bug.