Bug 469098 - Applet doesn't work with icedtea plugin but with sun plugin
Applet doesn't work with icedtea plugin but with sun plugin
Status: CLOSED DUPLICATE of bug 468490
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 17:09 EDT by Dennis Jacobfeuerborn
Modified: 2008-11-14 15:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 15:58:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output in shell (8.63 KB, text/plain)
2008-10-29 17:09 EDT, Dennis Jacobfeuerborn
no flags Details
Contents of java.stderr (19.17 KB, text/plain)
2008-10-29 17:10 EDT, Dennis Jacobfeuerborn
no flags Details

  None (edit)
Description Dennis Jacobfeuerborn 2008-10-29 17:09:49 EDT
Created attachment 321867 [details]
Output in shell

We have a KVM switch here that uses a java applet to display the video signal of connected machines in a window. This applet works fine with the plugin of Suns Java but not the OpenJDK plugin.

Attached are java.stderr and the shell output of a Firefox session with ICEDTEAPLUGIN_DEBUG set to "true". java.stdout just contains "JNLPRuntime already initialized".
Comment 1 Dennis Jacobfeuerborn 2008-10-29 17:10:48 EDT
Created attachment 321868 [details]
Contents of java.stderr
Comment 2 Deepak Bhole 2008-10-30 10:16:34 EDT
According to stderr, the error is:

Exception in thread "Applet" java.lang.ClassFormatError: Incompatible magic value 1008813135 in class file nn/pp/rc/RemoteConsoleApplet

Do you happen to know how the classes were compiled? (i.e. which compiler version, vendor, flags, etc.)
Comment 3 Dennis Jacobfeuerborn 2008-10-30 11:09:32 EDT
No Idea. This applet is part of the web interface embedded in the device so it's pretty much a black box.

Usually I wouldn't have filed a bug because of this black box nature but the Sun plugin apparently shows a different behavior than the icedtea one so I'm not sure if that is intended/desired.
Comment 4 Charles R. Anderson 2008-11-13 10:41:29 EST
Is
Comment 5 Deepak Bhole 2008-11-14 15:58:21 EST
This failure is caused by the same issue that causes bug #468490. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 468490 ***

Note You need to log in before you can comment on or make changes to this bug.