This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 468520 - olpcsound doesn't compile on rawhide
olpcsound doesn't compile on rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: olpcsound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Victor Lazzarini
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOLPCDelta
  Show dependency treegraph
 
Reported: 2008-10-25 10:57 EDT by Peter Robinson
Modified: 2009-04-06 07:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 07:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-10-25 10:57:35 EDT
Description says it all but details in koji build http://koji.fedoraproject.org/koji/taskinfo?taskID=902920
Comment 1 Victor Lazzarini 2008-10-25 13:00:36 EDT
The olpcsound package is not designed to be built on PPC, as it
is olpc-only, hence i386. This can be fixed, but I am not sure
it needs to be. What we need is an update to the csound package
(upstream sources now are 5.09).

In fact, I think it was never built on PPC.

I looked at the report and the scons error

Checking for C header file stdio.h... 
no
 *** Failed to compile a simple test program. The compiler is
 *** possibly not set up correctly, or is used with invalid flags.
 *** Check config.log to find out more about the error.

seems to indicate the build system is funny. Last time I
saw this happen, it had to do with the use ccache, which
scons does not seem to like.

I am not sure exactly how to tackle this, but in general I
think the objective of the olpcsound package is to have
a version of Csound tuned to the XO needs.
Comment 2 Peter Robinson 2008-10-26 17:58:35 EDT
Looking at the spec file for csound it looks like its not so much ppc that's the issue but rather that it has an issue with 64 bit. The plan was to get all the OLPC packages in mainline fedora so as to minimise the duplication. I'll have a look at this later in the week and see if the new upstream package doesn't improve the situation if that fails I'll look at either excluding the problematic arches or using the same hacks that csound uses which would allow the package to work on all platforms and hence allow wider testing.
Comment 3 Victor Lazzarini 2008-10-27 05:17:08 EDT
Could you look at the csound(-5.07) package? I think there is
a patch or spec directive there dealing with 64-bit architectures.
Since olpcsound and csound are one and the same as far as build
system etc (olpcsound is a subset), this might work on olpcsound
too. 

I am planning to update the csound package, but I have not had time
yet.
Comment 4 Peter Robinson 2008-11-20 07:44:47 EST
I've applied "ExclusiveArch: i386" for the moment to get it into mainline.
Comment 5 Bug Zapper 2008-11-25 23:14:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Peter Robinson 2008-12-15 15:52:39 EST
olpcsound has even more problems in the current rawhide with python 2.6.

Build logs here http://koji.fedoraproject.org/koji/getfile?taskID=999574&name=build.log
Comment 7 Victor Lazzarini 2008-12-15 16:02:31 EST
I saw this earlier today. The failure to compile seems to indicate an
scons problem. It can't even find 'stdio.h'. It might not be a Python2.6
issue: I saw this problem happen before because of ccache. I am wondering
if that is the same problem. Is it possible to check if ccache is being used?
Also: are there any other packages using scons being built on FC10?
Comment 8 Peter Robinson 2009-04-06 07:15:39 EDT
Closing as olpcsound will be obsolete when csound is upgraded to the latest version. details in this bug 473185

Note You need to log in before you can comment on or make changes to this bug.