Bug 473185 - Conflicts with csound
Conflicts with csound
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: olpcsound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
: Reopened
: 517358 (view as bug list)
Depends On: 493107
Blocks: FedoraOLPCDelta
  Show dependency treegraph
 
Reported: 2008-11-26 18:35 EST by Michael Schwendt
Modified: 2009-08-13 16:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.10.1-9.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 07:32:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-11-26 18:35:38 EST
> olpcsound is a subset of the Csound sound and music 
> synthesis system, tailored specifically for  XO platform.

Pardon?

Still you can set proper "Conflicts" tags. In particular, since this
package provides the same SONAMEs as csound:

olpcsound-5.08.92-12.fc11.i386  in  rawhide-development-i386
  File conflict with: csound-5.03.0-16.fc9.i386
     /usr/bin/csound
     /usr/lib/csound/plugins/libbarmodel.so
     /usr/lib/csound/plugins/libcompress.so
     /usr/lib/csound/plugins/libgrain4.so
     /usr/lib/csound/plugins/libharmon.so
     /usr/lib/csound/plugins/libloscilx.so
     /usr/lib/csound/plugins/libminmax.so
     /usr/lib/csound/plugins/libmixer.so
     /usr/lib/csound/plugins/libmodal4.so
     /usr/lib/csound/plugins/libphisem.so
     /usr/lib/csound/plugins/libphysmod.so
     /usr/lib/csound/plugins/libpitch.so
     /usr/lib/csound/plugins/libpvoc.so
     /usr/lib/csound/plugins/librtalsa.so
     /usr/lib/csound/plugins/libsfont.so
     /usr/lib/csound/plugins/libstackops.so
     /usr/lib/csound/plugins/libstdopcod.so
     /usr/lib/csound/plugins/libstdutil.so
     /usr/lib/csound/plugins/libudprecv.so
     /usr/lib/csound/plugins/libudpsend.so
     /usr/lib/csound/plugins/libugakbari.so
     /usr/lib/csound/plugins/libvaops.so
     /usr/lib/libcsound.so.5.1
  File conflict with: csound-jack-5.03.0-16.fc9.i386
     /usr/lib/csound/plugins/librtjack.so
  File conflict with: csound-osc-5.03.0-16.fc9.i386
     /usr/lib/csound/plugins/libosc.so
  File conflict with: csound-python-5.03.0-16.fc9.i386
     /usr/lib/python2.5/site-packages/_csnd.so
     /usr/lib/python2.5/site-packages/csnd.pyc

olpcsound-devel-5.08.92-12.fc11.i386  in  rawhide-development-i386
  File conflict with: csound-devel-5.03.0-16.fc9.i386
     /usr/include/csound/CsoundFile.hpp
     /usr/include/csound/OpcodeBase.hpp
     /usr/include/csound/csdl.h
     /usr/include/csound/csound.h
     /usr/include/csound/csound.hpp
     /usr/include/csound/csoundCore.h
     /usr/include/csound/cwindow.h
     /usr/include/csound/filebuilding.h
     /usr/include/csound/pstream.h
     /usr/include/csound/pvfileio.h
     /usr/include/csound/soundio.h
     /usr/include/csound/sysdep.h
     /usr/include/csound/text.h
     /usr/include/csound/version.h
Comment 1 Matěj Cepl 2008-11-28 14:47:19 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 2 Michael Schwendt 2008-12-09 16:04:14 EST
F10 is affected, too.
Comment 3 Michael Schwendt 2009-02-10 07:32:02 EST
Still reproducible with:

olpcsound-5.08.92-15.fc11
csound-5.03.0-20.fc11
Comment 4 Victor Lazzarini 2009-02-10 08:05:27 EST
As I said before olpcsound was never meant to anything but
a XO (OLPC) specific subset of Csound. (What do you mean
with "pardon?"?) 

I don't know what you want,
somehow this package was moved to be built for other targets than
OLPC, which was meant in the beginning.

So if you have a suggestion for a solution, please say so, because
I am not sure what needs to be done here.
Comment 5 Michael Schwendt 2009-02-10 09:21:36 EST
If this package is in Fedora 10 and Fedora 11 Development by mistakes, then contact Fedora Release Engineering and request removal. If you haven't done these builds, reassign this ticket to the right person, please.

All I see is a package that conflicts with other packages and also conflicts with SONAME Provides. That's bad.

I'd like to see this getting fixed. I'm willing to take this in front of FESCo or similar if you continue with such desinterest.
Comment 6 Victor Lazzarini 2009-02-10 09:34:34 EST
OK, I am happy to make any changes to the package as long as I know
what changes need to be done, which I don't. If you know what needs to be
done, please let me know. It is not a question of disinterest.
Comment 7 Victor Lazzarini 2009-02-10 09:49:40 EST
I have requested the removal of olpcsound from the FC* targets:

https://bugzilla.redhat.com/show_bug.cgi?id=484886
Comment 8 Victor Lazzarini 2009-02-10 10:16:03 EST
Looking at http://fedoraproject.org/wiki/Packaging/Conflicts
I am not allowed to mark the package with a Conflicts field. The
only other solution would be to rename binaries, but there are
olpc programs that link to the existing libraries and these
will be broken. So that would be perhaps more confusing.

Another solution is to remove the Csound 5.03 package, which
is old and obsolete. In fact, there is a newer package version
5.07 http://koji.fedoraproject.org/koji/buildinfo?buildID=17314
which should have been the one to be included in FC builds instead
(that would also cause conflicts nevertheless).
Comment 9 Michael Schwendt 2009-02-10 10:23:44 EST
You misread the packaging guidelines. Take your time and read them more slowly.

Btw, even with explicit "Conflicts:" tags in this package, there would still be the conflicting SONAME Provides, which require another fix.

I've contacted the person in charge of the Fedora builds. [Something's wrong here. The pkgdb doesn't list him at all.] If you don't take care of these builds, you ought not be the one to receive the bugzilla tickets.
Comment 10 Victor Lazzarini 2009-02-10 10:43:09 EST
> You misread the packaging guidelines. Take your time and read them more 
> slowly.

To me it reads like there is a file conflicts issue and renaming is
what they tell you to do. The only other chance for using Conflicts is
to ask them permission. You can enlighten me otherwise.

> Btw, even with explicit "Conflicts:" tags in this package, there would still > be the conflicting SONAME Provides, which require another fix.

I don't know how to fix this.

> If you don't take care of these
> builds, you ought not be the one to receive the bugzilla tickets.

I was the packager and maintained the OLPC-N builds, I have never
built the FC ones. I see that probinson was the person doing
the FC builds. Should this be reassigned to him?
Comment 11 Michael Schwendt 2009-02-10 11:24:59 EST
http://fedoraproject.org/wiki/Packaging/Conflicts#Implicit_Conflicts

is what is relevant here.


> The only other chance for using Conflicts is
> to ask them permission.

Yes, that ought to be done, if there is no other fix.


[...]

The conflicting SONAME Provides are this (that multiple csound pkgs provide it is another separate problem):

$ repoquery --whatprovides libcsound.so.5.1
csound-jack-0:5.03.0-20.fc11.i386
csound-java-0:5.03.0-20.fc11.i386
csound-fluidsynth-0:5.03.0-20.fc11.i386
csound-python-0:5.03.0-20.fc11.i386
csound-0:5.03.0-20.fc11.i386
csound-tk-0:5.03.0-20.fc11.i386
olpcsound-0:5.08.92-15.fc11.i386       <-- (!)
csound-dssi-0:5.03.0-20.fc11.i386
csound-osc-0:5.03.0-20.fc11.i386
csound-virtual-keyboard-0:5.03.0-20.fc11.i386
csound-fltk-0:5.03.0-20.fc11.i386

Typically, the shorted package name (of a pkg that provides something) wins during Yum depsolving, but that's not the point here. Here are implicit conflicts in files and library sonames, and they are not allowed.
Comment 12 Victor Lazzarini 2009-02-10 11:33:11 EST
Thanks. I suppose if we end up having to change the SONAME, that
will break the packages linked agains olpcsound in OLPC, will
it not?

I see that the if this is an implicit conflict, then we can just
mark it as so in the spec.
Comment 13 Peter Robinson 2009-03-30 11:00:07 EDT
I've been slowly investigating this in my spare time (which has been minimal during march but is improving this week) and it seems that once we get Fedora up to csound versions either 5.08 or 5.10 the olpcsound package can just go away all together. See a short discussion on the olpc-devel list [1] and the requirements of sugar 0.84 [2] for more details. It seems the main reason Fedora has such an ancient version of csound is due to lack of time for the maintainer (See bug 250829 for details). I'm in the process of updating the spec for a 5.10.1 build that builds on rawhide and will file a bug, which this one will depend on, with the updated csound package and we'll take it from there.

[1] http://lists.laptop.org/pipermail/devel/2009-March/023900.html
[2] http://wiki.sugarlabs.org/go/Development_Team/Sugar_Platform/0.84
Comment 14 Peter Robinson 2009-04-04 15:41:26 EDT
I've created an updated csound package and filed a bug to update csound to 5.10, once this is done olpc sound can be obsoleted by csound and be marked as a dead package.
Comment 15 Bug Zapper 2009-06-09 05:57:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Peter Robinson 2009-06-18 07:39:16 EDT
I've just built csound 5.10.1-7 for F-12/rawhide which obsoletes olpcsound. Victor are you happy if I mark olpcsound as a dead package as I think now with csound 5.10 in mainline now everything that is needed by OLPC is now included in csound?
Comment 17 Fedora Update System 2009-06-22 11:50:50 EDT
csound-5.10.1-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/csound-5.10.1-7.fc11
Comment 18 Fedora Update System 2009-06-24 15:37:44 EDT
csound-5.10.1-7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update csound'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6801
Comment 19 Fedora Update System 2009-06-30 17:34:10 EDT
csound-5.10.1-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Michael Schwendt 2009-07-09 02:56:18 EDT
oplcsound still conflicts with csound in Rawhide.


* The Obsoletes added to csound are not high enough.

> Obsoletes: olpcsound <= 5.08

Ought to be:

> Obsoletes: olpcsound <= 5.08.92


* The Obsoletes for olpcsound-devel are missing.


* olpcsound ought to be removed from Rawhide. If it cannot be untagged, ask Fedora Release Engineering to do it.
Comment 21 Peter Robinson 2009-07-16 07:32:54 EDT
Fixed in rawhide. I will get the olpcsound untagged.
Comment 22 Peter Robinson 2009-08-13 16:03:06 EDT
*** Bug 517358 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.