Bug 468616 - Banshee frequently crashes when switching tracks
Banshee frequently crashes when switching tracks
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch
Depends On: 469450
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-26 15:24 EDT by Ben Gamari
Modified: 2008-11-12 13:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 13:11:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Banshee debug output (22.94 KB, text/plain)
2008-10-26 15:24 EDT, Ben Gamari
no flags Details
Crash log with debugging symbols (40.17 KB, text/plain)
2008-10-29 11:36 EDT, Ben Gamari
no flags Details
Banshee 1.4.0.1-1 debug info (25.15 KB, application/octet-stream)
2008-11-11 03:29 EST, Peeter Puusemp
no flags Details

  None (edit)
Description Ben Gamari 2008-10-26 15:24:34 EDT
Created attachment 321556 [details]
Banshee debug output

Description of problem:
Banshee frequently crashes when advancing to the next track. This happens usually ever third track.

Version-Release number of selected component (if applicable):
banshee.x86_64                      1.2.1-2.fc10                       installed


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Nielsen 2008-10-29 09:15:54 EDT
if you can reproduce this then can you please try doing:

yum install yum-utils
debuginfo-install banshee

and then reproducing the crash with banshee --debug set

this will give us a more complete crash log.
Comment 2 Ben Gamari 2008-10-29 11:36:53 EDT
Created attachment 321816 [details]
Crash log with debugging symbols

Here's a new crash log. Produced by,
$ banshee-1 --debug &> h
I believe banshee crashed after the second or third song this time.
Comment 3 Ben Gamari 2008-10-29 11:38:58 EDT
Concerning the musical selection: don't judge, it's not mine. ;)
Comment 4 David Nielsen 2008-10-31 18:38:28 EDT
This sounds like:
https://bugzilla.redhat.com/show_bug.cgi?id=468616

Upstream has a patch for this which they have requested distributors ship in their packages. Once 469450 is closed this should be fixed. Thank you for your patience.
Comment 5 Peeter Puusemp 2008-11-11 03:29:37 EST
Created attachment 323156 [details]
Banshee 1.4.0.1-1 debug info
Comment 6 Peeter Puusemp 2008-11-11 03:43:53 EST
I installed banshee-1.4.0.1-1.fc10.i386 from Koji and Banshee still crashes randomly. Yesterday evening it didn't, but today morning it does. Yesterday I played more mp3 files, but today morning more FLAC files. It seems to crash after tracks in FLAC, but I cannot confirm it yet. Not after every track in FLAC, but after some of them.

I attached the debug info with the previous message.
Comment 7 Peeter Puusemp 2008-11-11 03:54:39 EST
I forgot to mention that I also installed podsleuth-0.6.3-1.fc10 and taglib-sharp-2.0.3.0-7.fc10 from Koji.

P.S. In Fedora 9 Banshee 1.2.1 worked with no problems. It started to happen when I did a fresh install of Fedora 10 Preview. Since I have played already quite some mp3 files now without a crash then it seems that Banshee 1.4.0 with those patches narrowed the problem to FLAC files.
Comment 8 Ben Gamari 2008-11-11 13:53:42 EST
Yeah, I've seen no improvement in the new package. It still crashes after a song or two.
Comment 9 David Nielsen 2008-11-11 14:22:11 EST
I've punted this to upstream as their proposed fix did not appear to work. You should both be on CC for the bug there.

http://bugzilla.gnome.org/show_bug.cgi?id=560392
Comment 10 David Nielsen 2008-11-11 16:19:27 EST
Reassigning to gstreamer as that is the cause

Downstream has a patch for this here:
http://bugzilla.gnome.org/show_bug.cgi?id=555631
Comment 11 Tom "spot" Callaway 2008-11-11 17:26:46 EST
I'm doing an F10 scratch build of a gstreamer with the patch referenced in 555631. I'd like some feedback as to whether this actually resolves the issue or not (I haven't really been able to reproduce these crashes):

http://koji.fedoraproject.org/koji/taskinfo?taskID=927657
Comment 12 Peeter Puusemp 2008-11-12 07:36:19 EST
(In reply to comment #11)
> I'm doing an F10 scratch build of a gstreamer with the patch referenced in
> 555631. I'd like some feedback as to whether this actually resolves the issue
> or not (I haven't really been able to reproduce these crashes):
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=927657

These new gstreamer packages seem to fix the problem.

Thank you all for the work on fixing this problem!
Comment 13 Ben Gamari 2008-11-12 11:53:09 EST
Yeah, I also haven't experienced any crashes since upgrading the gstreamer packages.
Comment 14 Tom "spot" Callaway 2008-11-12 13:11:04 EST
gstreamer-0.10.21-2.fc10 tagged into f10-final, closing this out.

Note You need to log in before you can comment on or make changes to this bug.