Bug 468656 - KeyError: <yuminstall.AnacondaYumRepo object at 0x7f3f178c0690>
KeyError: <yuminstall.AnacondaYumRepo object at 0x7f3f178c0690>
Status: CLOSED DUPLICATE of bug 457583
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 04:37 EDT by Alexander Todorov
Modified: 2008-10-28 03:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 03:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (177.18 KB, text/plain)
2008-10-27 04:37 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-10-27 04:37:05 EDT
Created attachment 321585 [details]
anacdump.txt

Description of problem:
Install of F10-Beta failed with traceback

Version-Release number of selected component (if applicable):
F10-Beta/anaconda-11.4.1.40

How reproducible:


Steps to Reproduce:
1. Create HVM Xen guest and boot from boot.iso
2. In stage 2 create disk layout:
/boot 100 ext3
/home 200 ext3, encrypted
LVM
  swap 512 encrypted
  /    all space, ext3, encrypted
3. At repo config screen add this repo (local mirror):
http://fedora.nano-box.net/linux/releases/test/10-Beta/Fedora/x86_64/os/
4. Deselect the official F10-rawhide repo and continue

Actual results:
Traceback (most recent call first):
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 115, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 238, in returnPrco
    cur = self._sql_MD('primary', sql, (self.pkgKey,))
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 823, in _checkInstall
    txmbr_reqs = txmbr.po.returnPrco('requires')
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 771, in _resolveRequires
    thisneeds = self._checkInstall(txmbr)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 688, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 641, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1300, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 255, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1349, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1479, in keyRelease
    self.nextClicked()
KeyError: <yuminstall.AnacondaYumRepo object at 0x7f3f178c0690>


Expected results:
No traceback

Additional info:
Comment 1 Alexander Todorov 2008-10-27 05:03:44 EDT
Using the official mirror list is not an option. I get 'Unable to read package metadata from repository' message.
Comment 2 Jeremy Katz 2008-10-27 10:06:23 EDT
Are you trying with the actual beta or one of the later snapshots?  If the former, this is a dupe of bug 457583 which got the fix pushed just past beta
Comment 3 Alexander Todorov 2008-10-28 03:40:12 EDT

*** This bug has been marked as a duplicate of bug 457583 ***

Note You need to log in before you can comment on or make changes to this bug.