Bug 468710 - Preupgrade fails to update to Rawhide
Preupgrade fails to update to Rawhide
Status: CLOSED DUPLICATE of bug 459935
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 11:46 EDT by Oded Arbel
Modified: 2014-01-21 18:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 12:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2008-10-27 11:46:38 EDT
Description of problem:
When running preupgrade (both GTK and CLI interfaces) to upgrade Rawhide, it runs for a while and then throws an exception and gets stuck.

The error thrown is:
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib64/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'

(its similar in the CLI version except that the file in the first few calls in the stack is preupgrade-cli).

After the exception the CLI program exists while the GTK program stays stuck with the message "downloading installer metadata: 92.5%"

Version-Release number of selected component (if applicable):
0.9.3-3.fc9.noarch

How reproducible:
Always

Steps to Reproduce:
1. run preupgrade-cli Rawhide
2. Answer Y for the upgrade confirmation
  
Actual results:
Exception thrown

Expected results:
The preupgrade should complete

Additional info:
Comment 1 Will Woods 2008-10-27 12:04:57 EDT

*** This bug has been marked as a duplicate of bug 446237 ***
Comment 2 Will Woods 2008-10-27 12:07:20 EDT
Err, whoops. Got the wrong bug.

*** This bug has been marked as a duplicate of bug 459935 ***

Note You need to log in before you can comment on or make changes to this bug.