This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 446237 - "No more mirrors" traceback from retrieve_treeinfo
"No more mirrors" traceback from retrieve_treeinfo
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 451431 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 12:57 EDT by Nicholas Miell
Modified: 2008-11-26 01:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:12:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicholas Miell 2008-05-13 12:57:33 EDT
Description of problem:

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 372, in
retrieve_treeinfo
    tif = self.distrepo.grab.urlopen('/.treeinfo')
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 417, in urlopen
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 390, in
_mirror_try
    mirrorchoice = self._get_mirror(gr)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 287, in
_get_mirror
    raise URLGrabError(256, _('No more mirrors to try.'))
urlgrabber.grabber.URLGrabError: [Errno 256] No more mirrors to try.

Version-Release number of selected component (if applicable):
preupgrade-0.9.3-2.fc8

How reproducible:


Steps to Reproduce:
1. Try to preupgrade to a new Fedora release on release day
2. Experience heavy mirror load
  
Actual results:
A traceback and then UI stops progressing through the preupgrade steps

Expected results:
Preupgrade retries all downloads until it succeeds, while displaying a download
attempt counter so the user knows what's going on.

Additional info:
Comment 1 Nicholas Miell 2008-05-13 14:42:05 EDT
apparently this was the result of bug #446244, so preupgrade correctly
determined that none of the mirrors in the mirrorlist actually had a .treeinfo,
but the resulting lack of information from the UI is still a problem
Comment 2 Will Woods 2008-05-13 14:52:57 EDT
Correct, and bug #446244 should be fixed in a new preupgrade package that's
currently building. 

Still need to improve the UI for this error condition though.
Comment 3 Will Woods 2008-09-29 14:07:20 EDT
In preupgrade-0.9.8 we pop up an error dialog with "Retry" and "Quit" buttons.
Comment 4 Fedora Update System 2008-10-02 19:03:59 EDT
preupgrade-0.9.8-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-0.9.8-2.fc9
Comment 5 Fedora Update System 2008-10-02 19:04:08 EDT
preupgrade-0.9.8-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/preupgrade-0.9.8-2.fc8
Comment 6 Fedora Update System 2008-10-03 18:28:39 EDT
preupgrade-0.9.8-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 7 Fedora Update System 2008-10-03 18:31:58 EDT
preupgrade-0.9.8-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 8 Will Woods 2008-10-20 14:44:30 EDT
*** Bug 451431 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2008-10-23 12:36:48 EDT
preupgrade-0.9.8-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 10 Fedora Update System 2008-10-23 12:40:08 EDT
preupgrade-0.9.8-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 11 Will Woods 2008-10-27 12:04:57 EDT
*** Bug 468710 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2008-11-11 21:58:25 EST
preupgrade-0.9.9-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 13 Fedora Update System 2008-11-11 21:59:24 EST
preupgrade-0.9.9-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 14 Fedora Update System 2008-11-21 18:48:52 EST
preupgrade-1.0.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.0-1.fc10
Comment 15 Fedora Update System 2008-11-26 01:12:19 EST
preupgrade-1.0.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-11-26 01:13:23 EST
preupgrade-1.0.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2008-11-26 01:21:51 EST
preupgrade-1.0.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.