Bug 468808 - system-config-network crashed when saving any config
system-config-network crashed when saving any config
Status: CLOSED DUPLICATE of bug 468574
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 01:43 EDT by Luo Bin
Modified: 2008-10-28 09:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 09:35:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luo Bin 2008-10-28 01:43:05 EDT
Description of problem:
system-config-network crashed when saving any config,even you do configure nothing but only opened it and clicked the save buttom.

Version-Release number of selected component (if applicable):
system-config-network-1.5.92-3.fc10 on rawhide

How reproducible:
Open system-config-network, and try to save any config!


Steps to Reproduce:
1.Open system-config-network
2.input your root passwaord
3.save the config
  
Actual results:
system-config-network crashed,and give the output of error:
[xelnaga@ASUS6 ~]$ system-config-network
Component: system-config-network
Version: 1.5.92
Summary: TBcba504d9 ConfModules.py:93:__setitem__:TypeError: cannot concatenate 'str' and 'NoneType' objects

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 829, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 410, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 438, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 738, in save
    hw.save()
  File "/usr/share/system-config-network/netconfpkg/plugins/NCPluginHWEthernet.py", line 58, in save
    modules[self.Name] = dic
  File "/usr/share/system-config-network/netconfpkg/conf/ConfModules.py", line 93, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: cannot concatenate 'str' and 'NoneType' objects

Local variables in innermost frame:
findexp: ^[	 ]*alias[	 ]+pan0[	 ]+
missing: 1
varname: pan0
self: <netconfpkg.NCHardwareList.MyConfModules instance at 0x878c80c>
value: {'alias': None}
place: 0
key: alias
endofline: None

Expected results:
system-config-network exit normally


Additional info:
Comment 1 Harald Hoyer 2008-10-28 09:35:11 EDT

*** This bug has been marked as a duplicate of bug 468574 ***

Note You need to log in before you can comment on or make changes to this bug.