Bug 468574 - TB24531662 NCBackendHal.py:103:getDevices:TypeError: not enough arguments for format string
TB24531662 NCBackendHal.py:103:getDevices:TypeError: not enough arguments for...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 468666 468808 468854 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-26 02:50 EDT by Joachim Frieben
Modified: 2008-10-28 09:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 12:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception output saved to a file (2.59 KB, text/plain)
2008-10-26 02:50 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-10-26 02:50:03 EDT
Created attachment 321541 [details]
Exception output saved to a file

Description of problem:
After a fresh install of F10-Snap3 and pending "rawhide" updates, it is impossible to create new network connections by means of s-c-n which throws an exception right after launch.

Version-Release number of selected component (if applicable):
system-config-network-1.5.10-1.fc9.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install F10-Snap3 plus updates including hal-0.5.12-7.20081022git.fc10.
2. Launch s-c-n.
  
Actual results:
s-c-n reports an exception.

Expected results:
s-c-n starts up and allows to manage network connections as expected.

Additional info:  The current s-c-n package was built on Tue 27 May 2008 for F9 and never rebuilt for F10 in a recent environment. Looks like there has been an API change in hal.
Comment 1 Joachim Frieben 2008-10-26 04:22:56 EDT
F10-Snap3 exhibits the same issue whereas F10-Snap2 worked well in this respect.
Comment 2 Joachim Frieben 2008-10-27 12:44:15 EDT
Fixed in system-config-network-1.5.92-2.fc10.
Comment 3 Harald Hoyer 2008-10-28 09:35:11 EDT
*** Bug 468808 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2008-10-28 09:35:23 EDT
*** Bug 468854 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2008-10-28 09:36:13 EDT
*** Bug 468666 has been marked as a duplicate of this bug. ***
Comment 6 Stefan Seefeld 2008-10-28 09:39:53 EDT
Is there an F9 package for system-config-network-1.5.92-2 that I can upgrade to ?
Comment 7 Harald Hoyer 2008-10-28 09:44:33 EDT
will build one.

Note You need to log in before you can comment on or make changes to this bug.