Bug 468860 - Intel driver, no glx output
Intel driver, no glx output
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 10:09 EDT by Karl Lattimer
Modified: 2018-04-11 02:47 EDT (History)
10 users (show)

See Also:
Fixed In Version: updates as of 2009-02-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 12:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg conf (1.55 KB, text/plain)
2008-10-29 05:52 EDT, Karl Lattimer
no flags Details
xorg.log file produce when using the previously submitted conf file (85.98 KB, text/plain)
2008-10-29 05:57 EDT, Karl Lattimer
no flags Details
xorg.log file produce when not using any xorg.conf (86.31 KB, text/plain)
2008-10-29 05:58 EDT, Karl Lattimer
no flags Details

  None (edit)
Description Karl Lattimer 2008-10-28 10:09:42 EDT
Description of problem:
using the intel driver in my xorg.conf results in a lack of any OpenGL output to the screen, glxgears results in a black box which still spits out the number of frames drawn but unfortunately fails to put out any image to the screen.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.5.0-1.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. set the driver in xorg.conf to intel
2. try running a GL app
  
Actual results:
black output

Expected results:
real GL output

Additional info:
lcpci says graphics chip is;

Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 1 Matěj Cepl 2008-10-28 19:50:22 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Karl Lattimer 2008-10-29 05:52:07 EDT
Created attachment 321771 [details]
xorg conf

the xorg conf file i have been using
Comment 3 Karl Lattimer 2008-10-29 05:57:34 EDT
Created attachment 321772 [details]
xorg.log file produce when using the previously submitted conf file
Comment 4 Karl Lattimer 2008-10-29 05:58:43 EDT
Created attachment 321773 [details]
xorg.log file produce when not using any xorg.conf
Comment 5 Karl Lattimer 2008-10-29 06:19:06 EDT
I've also experienced a few complete lockups when testing this so there's most likely something wrong with the driver, rather than the configuration.
Comment 6 Kjartan Maraas 2008-11-05 09:07:04 EST
Just a datapoint. glxgears works for me with the intel driver on a HP Compaq nc6400 laptop:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 7 Karl Lattimer 2008-11-05 09:13:45 EST
Kjartan, are you using rawhide?

which package version?
Comment 8 Kjartan Maraas 2008-11-05 10:43:13 EST
Yes. I'm using rawhide with the same version of the driver that you listed above. Are you using compiz? :-)
Comment 9 Karl Lattimer 2008-11-05 11:27:32 EST
nope, I can't use compiz, because i can't get any GL to work at all :/
Comment 10 Bug Zapper 2008-11-25 23:21:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Gen Zhang 2008-11-28 08:44:24 EST
This still occurs for me on a mactel mac mini. Fresh install, no xorg.conf at all. glxinfo reports everything is fine, glxgears thinks things are fine, but only produces a black box. compiz crashes the machine hard. I can upload a smolt profile if that would be helpful.
Comment 12 Simon Lanzmich 2009-01-06 14:05:12 EST
I'm having the same problem on my MacBook running Fedora 10. However, it disappears (i.e. glxgears works fine) after resuming from suspend to RAM.
Comment 13 keith 2009-01-28 13:43:07 EST
I got here after failing to enable opengl rendering on mythtv.
Found afterwards I couldn't run compiz and saw I get the same black box when running glxgears.

This is all on an intel mac mini.

Compiz gives this error:
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

although glxinfo shows GLX_EXT_texture_from_pixmap is present.

I am running up to date F10 with no xorg.conf ...
xorg-x11-drv-i810-2.5.0-4.fc10
kernel-2.6.27.12-170.2.5.fc10


Smolt : http://www.smolts.org/client/show/pub_1047b16c-1ecc-452d-a99a-294c11c19f20
Comment 14 keith 2009-01-29 05:31:05 EST
Doing some testing as suggested by some other posts to see if forcing XAA would help.
Major crash of X resulted ...
Comment 15 keith 2009-02-18 06:16:56 EST
Hi,

As of updates yesterday, this bug has gone for me.
I can now see glxgears again :-)
Comment 16 Karl Lattimer 2009-02-19 04:55:15 EST
I still have the problem, all most recent updates (i think) I've got package version xorg-x11-drv-i810-2.5.0-4.fc10.i386 it's definitely not fixed here.
Comment 17 Matěj Cepl 2009-02-19 12:42:38 EST
Try to upgrade tomorrow (so that we are sure it is not something about slow mirrors) and let us know.
Comment 18 Karl Lattimer 2009-02-19 18:49:37 EST
can someone tell me which package version is supposed to be working? I can't find any package newer than xorg-x11-drv-i810-2.5.0-4.fc10.i386 in the updates or updates-testing repository. 

If I have the newest version then waiting for an update isn't going to help, especially as I disabled the mirrors and tried to get an update directly from fedoraproject.org
Comment 19 keith 2009-02-20 09:38:53 EST
I will check my yum log and see if I can spot which it might have been.
There wasn't an i810 driver update though from what I can remember.
Comment 20 keith 2009-02-20 11:23:39 EST
I tested after I had these updates come through when everything worked:
Feb 15 10:22:18 Updated: compiz-0.7.8-7.fc10.i386
Feb 15 10:22:40 Updated: policycoreutils-2.0.57-17.fc10.i386
Feb 15 10:22:44 Updated: 1:pkgconfig-0.23-6.fc10.i386
Feb 15 10:22:46 Updated: elfutils-libelf-0.139-1.fc10.i386
Feb 15 10:22:49 Updated: nss_ldap-264-1.fc10.i386
Feb 15 10:22:52 Updated: procps-3.2.7-22.fc10.i386
Feb 15 10:22:54 Updated: 2:ntfs-3g-2009.2.1-1.fc10.i386
Feb 15 10:23:29 Updated: gnome-power-manager-2.24.4-1.fc10.i386
Feb 15 10:23:30 Updated: ethtool-6-2.20090115git.fc10.i386
Feb 15 10:23:31 Updated: 1:xorg-x11-drv-nouveau-0.0.11-1.20090106git133c1a5.fc10.i386
Feb 15 10:23:32 Updated: xorg-x11-drv-ati-6.10.0-2.fc10.i386
Feb 15 10:23:34 Updated: 1:nfs-utils-1.1.4-8.fc10.i386
Feb 15 10:23:56 Updated: selinux-policy-3.5.13-44.fc10.noarch
Comment 21 keith 2009-02-20 11:37:48 EST
After more testing, although glxgears is now functioning correctly, compiz and mythtv with opengl doesnt work.
Compiz still reports the same error : GLX_EXT_texture_from_pixmap is missing
Comment 22 Karl Lattimer 2009-03-15 10:11:23 EDT
After much testing of various options I've found the following options give some gl output;

Option "TripleBuffer" "true"
Option "PageFlip" "true"

See my post here http://www.qdh.org.uk/wordpress/?p=278 for a screenshot of the current output and a little more info.

Compiz is working for me, albeit slow, texture_from_pixmap is present when using indirect rendering.
Comment 23 Kai Willadsen 2009-03-15 18:19:43 EDT
The upstream bug for this is:
http://bugs.freedesktop.org/show_bug.cgi?id=18430
Comment 24 Adam Williamson 2009-03-18 11:02:27 EDT
Reassigning to the correct group rather than ajax personally.

Out of interest, how's it look in Rawhide? If installing Rawhide would be inconvenient, give this live CD a shot:

http://katzj.fedorapeople.org/testday/livecd-fedora-livecd-desktop-200903161319-i386.iso

(or http://katzj.fedorapeople.org/testday/livecd-fedora-livecd-desktop-200903161250-x86_64.iso for x86-64)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Kai Willadsen 2009-03-18 11:14:32 EDT
I haven't tried that particular livecd yet, but for me at least the one from the test day was not so promising:
https://bugzilla.redhat.com/show_bug.cgi?id=490496
Comment 26 Adam Williamson 2009-03-18 12:28:14 EDT
Oh, fun!

Well, neither of those problems are typical for 945s (I have one on my test intel system and both regular operation and glxgears worked fine on the test day live image and in f10 with that), so it seems like there's really something odd about the macbook implementation. :\ thanks for the info.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Kjartan Maraas 2009-04-29 06:01:36 EDT
With rawhide from today I see the gears, but the background is white. Is this how it's supposed to be? I seem to remember that the background was black earlier.
Comment 28 Adam Williamson 2009-04-29 11:32:27 EDT
nope, it's still supposed to be black. :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Vedran Miletić 2009-11-05 18:11:34 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, including Intel driver, which may have resolved this issue.
To be more precise, Intel has undergone a major rewrite during Fedora 10, 11 and 12 cycles, and whole driver is working a lot better now. Users who have experienced this problem are encouraged to retry with at least Fedora 12 Beta and see if the issue is still relevant.

Please, if you experience this problem on Fedora 12 Beta or up-to-date system running Rawhide, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

We hope to see how many older bugs in Intel driver are still relevant today, in hope that most of them were fixed in rewrite process.

[This is a bulk message for all open Fedora 10 i810-related bugs (39 of them are still open). I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 30 Bug Zapper 2009-11-18 03:40:51 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 31 Vedran Miletić 2009-12-04 12:56:52 EST
Thank you for your bug report.

We are sorry, but the Fedora Project is will soon stop longer releasing bug fixes or any other updates for this version of Fedora. There were so many changes between Fedora 10 and Fedora 12 in Intel driver and X.Org that it's very likely that this bug is fixed. This bug will be set to CLOSED:WONTFIX to reflect this, but please reopen it if the problem persists after upgrading to the latest version of Fedora (version 12), which is available from:

http://fedoraproject.org/get-fedora

Note You need to log in before you can comment on or make changes to this bug.