Bug 490496 - X hangs at GDM with intel modesetting
X hangs at GDM with intel modesetting
Status: CLOSED DUPLICATE of bug 494390
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 495251 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 13:51 EDT by Kai Willadsen
Modified: 2009-04-17 12:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 12:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (38.84 KB, text/plain)
2009-03-31 09:55 EDT, Andrew Cathrow
no flags Details
lspci output - under F10 (not F11) (2.20 KB, text/plain)
2009-04-17 02:59 EDT, Fabian Deutsch
no flags Details

  None (edit)
Description Kai Willadsen 2009-03-16 13:51:19 EDT
Using the live CD image linked from
  http://fedoraproject.org/wiki/QA/Test_Days/2009-03-12
X hangs at GDM. Prior to GDM, the system appears to correctly mode switch during plymouth (judging by text size, etc.). At GDM, the wallpaper is sometimes painted, while other times the background is black. The cursor can be seen and moved, but is corrupted. The system is unresponsive to a VT switch.

As an aside, booting with nomodeset the system does not reach GDM, and in fact doesn't even seem to attempt to mode switch.

The system is a first-generation Macbook:
  http://www.smolts.org/show?uuid=pub_e4502255-7cc7-4724-9dda-8c7f9246f25e
Comment 1 Andrew Cathrow 2009-03-31 09:55:29 EDT
Created attachment 337303 [details]
Xorg log file
Comment 2 Andrew Cathrow 2009-03-31 09:56:07 EDT
Tested with latest rawhide on MacBook 2,1
http://www.smolts.org/client/show/pub_433b46e4-1e26-43d1-84f4-ca3bc00e7d79

Kernel 2.6.29-21.fc11.x86_64 
xorg-x11-server-Xorg-1.6.0-16
xorg-x11-drv-intel-2.6.99.902-1

After boot machine locks at login screen - sometimes with background drawn and corrupt mouse pointer, sometimes a blank screen with corrupted mouse pointer.

Tested booting into run level 3
Tried startx from command line
X starts and locks at black screen with corrupted mouse cursor
Machine has to be powered down to reset.

Attached Xorg logfile Xorg.0.log.aic
Comment 3 Kai Willadsen 2009-04-01 05:16:43 EDT
Retested with F11 beta on Macbook 1,1. KMS appears to work in so far as the plymouth graphical boot works, and appears to be at the correct resolution. However, the machine still locks at GDM with a corrupted (but moveable) mouse cursor. The background draws, but the login box is just a grey rectangle. VT switch doesn't work.
Comment 4 Fabian Deutsch 2009-04-16 04:42:58 EDT
*** Bug 495251 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2009-04-16 19:24:41 EDT
Can you give the output of 'lspci -nn'? I'm suspecting this may well be the same adapter as the Mac Mini, https://bugzilla.redhat.com/show_bug.cgi?id=494390 ...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Fabian Deutsch 2009-04-17 02:59:17 EDT
Created attachment 339962 [details]
lspci output - under F10 (not F11)

The output of lspci.

I took this under F10, not F11.
Comment 7 Adam Williamson 2009-04-17 12:49:34 EDT
Yep - same adapter: 8086:27a2 . That's the same chip, in two Mac systems - I think we can mark these as the same bug. There's a bit more info in that bug, so marking this as a dupe of that.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 494390 ***

Note You need to log in before you can comment on or make changes to this bug.