Bug 468861 - Bouncy autohide panels
Bouncy autohide panels
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-28 10:10 EDT by Nils Philippsen
Modified: 2008-11-06 05:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:52:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
video illustrating the problem (157.44 KB, video/x-theora+ogg)
2008-10-28 10:10 EDT, Nils Philippsen
no flags Details
video illustrating problems with unexpanded panels (713.24 KB, video/x-theora+ogg)
2008-11-05 07:27 EST, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2008-10-28 10:10:11 EDT
Created attachment 321696 [details]
video illustrating the problem

Description of problem:
Some of my autohide panels hide and unhide with a bouncy animation entirely too reminiscent of Homer Simpson's attempts to vote for a certain presidential candidate for my taste...

Version-Release number of selected component (if applicable):
gnome-panel-2.24.1-1.fc10.x86_64

How reproducible:
Reproducible.

Steps to Reproduce:
1. Add a new or have a panel at the left or right border of the desktop
2. Make it autohiding
3. Move mouse over it and away
  
Actual results:
Watch it bounce, wonder how you're supposed to hit the intended buttons in that panel (without waiting for the animation to finish that is).

Expected results:
Smooth motion from hidden to revealed state, just as it was before this bouncy thing was introduced.

Additional info:
- In my own panel setup of 4 autohiding panels (two expanded on top and bottom, two non-expanded on left and right oriented towards the bottom), I can easily get a new panel jump over half the screen: make the existing bottom panel non-autohiding, add a new non-expanded autohiding panel on top of it, voilà: panel floor exercises and pretty impressive ones.

- I noticed that in a freshly scrubbed account (i.e starting from /etc/skel), when adding a new panel it wasn't visible until I logged out and in again. Do you want a separate bug for that?
Comment 1 Nils Philippsen 2008-10-30 06:39:40 EDT
According to the definition, this is a regression:

'Bugs with the "Regression" keyword are items where a recent change has introduced this bug.'
Comment 2 Matthias Clasen 2008-10-30 21:48:15 EDT
That definition is incorrect though. A regression is a bug that was fixed and later reappears. 

This is just an ordinary bug.
Comment 3 Nils Philippsen 2008-10-31 06:00:44 EDT
(In reply to comment #2)
> That definition is incorrect though. A regression is a bug that was fixed and
> later reappears. 
> 
> This is just an ordinary bug.

There are differing opinions on this, according to Wikipedia (the source of all wisdom(tm)) on http://en.wikipedia.org/wiki/Software_regression:

A software regression is a software bug which makes a feature stop functioning as intended after a certain event (for example, a system upgrade, system patching or a change to daylight saving time).
[...]
The term regression was originally used to refer to a change that caused a previously fixed bug to reappear and the software to thus regress to a prior, incorrect state. Regression test suites were accordingly composed of tests which tried to ensure the continued effectiveness of past bug fixes. However, the term has since evolved to its current, more general meaning of any change that breaks existing functionality.
Comment 4 Ray Strode [halfline] 2008-10-31 09:38:16 EDT
Sure, but Matthias was giving the definition we use the keyword for.

But we don't use the keyword in Fedora anyway, it's only used for RHEL.

Anyway, regardless what we call it, it's still a bug and should get fixed clearly.
Comment 5 Matthias Clasen 2008-11-04 00:01:17 EST
The fix for this is in gnome-panel-2.24.1-3.fc10
Comment 6 Nils Philippsen 2008-11-05 07:27:41 EST
Created attachment 322562 [details]
video illustrating problems with unexpanded panels

The new gnome-panel version fixes the panels bouncing all over the place problem, but there are two (related/new?) issues:

1) Now the vertical panels slide in view, then bounce a few pixels upward and downward again in fractions of a second (this can't be seen in this video, it's happening too fast for istanbul to catch).

2) Unexpanded panels don't change orientation from horizontal to vertical when moved around. As can be seen in this video, they only recognize being attached to top or bottom, not left or right. I imagine if the panel is made vertical first, then non-expanding it will behave analogously, i.e. only recognize being attached left or right, not top or bottom.
Comment 7 Ray Strode [halfline] 2008-11-05 10:29:38 EST
I can't really reproduce 1).  So you have an unexpanded vertical panel that autohides, and each time you move your mouse to it, it stutters along the y axis a small amount? Or does this happen only when the panel first starts?  What vertical panel configurations do you see this issue with?

2) is an old issue and should be tracked separately (and probably won't get fixed for F10 GA)
Comment 8 Nils Philippsen 2008-11-05 11:47:07 EST
(In reply to comment #7)
> I can't really reproduce 1).  So you have an unexpanded vertical panel that
> autohides, and each time you move your mouse to it, it stutters along the y
> axis a small amount?

Yes. Talking about an unexpanded autohiding vertical panel at the right edge, if it's touching the (expanded, autohiding) top or bottom panel it stutters a bit upward (if touching the bottom panel) or downward (if touching the top panel). If it doesn't touch any panels, there is no stutter.

> Or does this happen only when the panel first starts? 
> What vertical panel configurations do you see this issue with?

No real changes since this: https://bugzilla.redhat.com/show_bug.cgi?id=102632#c7

> 2) is an old issue and should be tracked separately (and probably won't get
> fixed for F10 GA)

That's no problem for me, as you can work around it.
Comment 9 Ray Strode [halfline] 2008-11-05 13:52:06 EST
I definitely can't reproduce this, but maybe the timing is just right on my machine where i can't see it.

Anyway, mind filing it as a different bug?  The meat of this one is fixed and i'd like to get it closed.
Comment 10 Nils Philippsen 2008-11-06 05:48:10 EST
Filed as bug #470205.

Note You need to log in before you can comment on or make changes to this bug.