This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 468894 - modesetting: graphic card not correctly initialized after resume
modesetting: graphic card not correctly initialized after resume
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 13:39 EDT by Stefan Becker
Modified: 2009-09-12 04:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 04:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log before suspending (40.59 KB, text/plain)
2009-02-16 12:50 EST, Stefan Becker
no flags Details
X server log from Xorg.0.log.old after reboot (70.43 KB, text/plain)
2009-02-16 12:52 EST, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2008-10-28 13:39:53 EDT
Description of problem:

When the kernel is booted up with KMS enabled then the graphics card is not correctly initialized after resume from suspend-to-RAM or suspend-to-disk. It starts to draw random horizontal lines.

If you boot the kernel with "nomodeset" then resume works correctly.

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-58.fc10.i686
xorg-x11-server-utils-7.4-3.fc10.i386
xorg-x11-server-Xorg-1.5.2-10.fc10.i386
xorg-x11-drv-ati-6.9.0-34.fc10.i386

How reproducible: Always

Additional info:

$ lspci | fgrep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon
X1300]
$ lspci -n | fgrep 01:00.0
01:00.0 0300: 1002:7149Description of problem:
Comment 1 Bug Zapper 2008-11-25 23:22:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Stefan Becker 2008-12-10 14:07:04 EST
The latest build from koji mentioned resume, so I gave it a spin:

kernel-2.6.27.7-134.fc10.i686
xorg-x11-server-Xorg-1.5.3-5.fc10.i386
xorg-x11-drv-ati-6.9.0-62.fc10.i386

Resume is still broken with kernel mode setting :-(
Comment 3 Tom Davidson 2009-01-14 16:19:30 EST
Same problem here, with the same video card (M52; Mobility Radeon X1300 Mobility), on an Thinkpad T60, nearly fresh install of F10 at kernel 2.6.27.9-159. All packages updated as of Jan 12, '09.

Resume from suspend and from hibernate both result in random horizontal lines, even when suspend is called from runlevel 2 (i.e. no X server). Apart from the corrupt video, the system otherwise appears functional (can generate disk activity with 'find /', run 'reboot'...

Booting with 'nomodeset' kernel option solves the issue.

Cheers, Tom 

$ uname -a
Linux mamquam 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386 GNU/Linux

$ lspci|grep -i vga
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]

$ lspci -v -s 01:00.0
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300] (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 2005
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at d8000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 2000 [size=256]
	Memory at ee100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at ee120000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel modules: radeon
Comment 4 François Cami 2009-02-16 09:26:56 EST
Stefan, Tom,
Could you please confirm that this happens with 2.6.27.12-170.2.5.fc10 ?
If so, please (both of you) add dmesg and full /var/log/Xorg.0.log as uncompressed text/plain attachments to this bug. Xorg.0.log after a resume (by rebooting into runlevel 3 for instance) would be helpful too.

Switching Severity to low since nomodeset is an easy workaround ; adjusting Priority as well.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Stefan Becker 2009-02-16 12:50:29 EST
Created attachment 332072 [details]
dmesg log before suspending

Yes, the problem still exists:

kernel-2.6.27.12-170.2.5.fc10.i686
xorg-x11-drv-ati-6.10.0-2.fc10.i386
xorg-x11-server-Xorg-1.5.3-11.fc10.i386

Xorg.0.log will follow
Comment 6 Stefan Becker 2009-02-16 12:52:55 EST
Created attachment 332073 [details]
X server log from Xorg.0.log.old after reboot

The keyboard/power key was unresponsive after resume. So I had to use the 8-seconds-power-switch ACPI power off and therefore the X server log file doesn't seem to contain any additional information since before the suspend.

BTW: I'm using suspend-to-RAM.
Comment 7 Stefan Becker 2009-03-31 12:43:03 EDT
Test system moved to F11 rawhide. Retested with:

kernel-2.6.29-16.fc11.i586
libdrm-2.4.5-3.fc11.i586
xorg-x11-server-Xorg-1.6.0-15.fc11.i586
xorg-x11-drv-ati-6.12.0-2.fc11.i586

Graphic card is now correctly initialized after resuming from suspend-to-RAM or suspend-to-Disk.
Comment 8 François Cami 2009-04-01 16:20:48 EDT
Stefan,

Thanks for testing and making sure rawhide is not affected,
this is greatly appreciated.
Reopening since we need to track the status for F10.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Stefan Becker 2009-09-12 04:21:46 EDT
This will never be fixed in F10.

As F12 testing shows radeon KMS and suspend is still highly unreliable, see bug #522070

Note You need to log in before you can comment on or make changes to this bug.