Bug 468989 - arch-independent-package-contains-binary-or-object for MinGW packages
arch-independent-package-contains-binary-or-object for MinGW packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 07:49 EDT by Richard W.M. Jones
Modified: 2009-09-09 11:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 11:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2008-10-29 07:49:50 EDT
MinGW packaging guidelines were recently approved for Fedora:

http://fedoraproject.org/wiki/Packaging/MinGW

Most MinGW packages are 'noarch'.  The reason is that although
they contain Windows binary code for Windows/i386, they are noarch
from the point of view of the build architecture
(Fedora/i386/ppc/whatever).

Thus it is OK for these packages to contain, for example, *.a,
*.dll and *.exe Windows binary files.

Example:

mingw32-gdbm.noarch: E: arch-independent-package-contains-binary-or-object /usr/i686-pc-mingw32/sys-root/mingw/lib/libgdbm.dll.a
(bug 467391)

If you wanted to be really specific here, it's OK for them
to contain only Windows COFF files:

$ file /usr/i686-pc-mingw32/sys-root/mingw/lib/libgdbm.dll.a 
/usr/i686-pc-mingw32/sys-root/mingw/lib/libgdbm.dll.a: current ar archive
$ cd /tmp
$ mkdir unpack
$ cd unpack/
$ ar x /usr/i686-pc-mingw32/sys-root/mingw/lib/libgdbm.dll.a 
$ file *
d000000.o: 80386 COFF executable not stripped - version 24932
d000001.o: 80386 COFF executable not stripped - version 30821
[...]

If a MinGW noarch package contained Fedora native binaries then
that shouldn't happen and it would be a bug.
Comment 1 Bug Zapper 2008-11-25 23:25:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Richard W.M. Jones 2009-09-09 11:41:26 EDT
Closing - rpmlint no longer reports this as a problem.

Note You need to log in before you can comment on or make changes to this bug.