Bug 469074 - Can not build qemu from source rpm (.srpm)
Can not build qemu from source rpm (.srpm)
Status: CLOSED DUPLICATE of bug 465041
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 14:50 EDT by Paul Bolle
Modified: 2009-03-25 12:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The log produced by 'mock' command (2.28 KB, application/octet-stream)
2009-03-18 14:49 EDT, Massimiliano
no flags Details

  None (edit)
Description Paul Bolle 2008-10-29 14:50:38 EDT
Description of problem:
Building qemu from its source rpm fails

Version-Release number of selected component (if applicable):
qemu-0.9.1-10.fc10.i386 (i.e. qemu-0.9.1-10.fc10.src.rpm)

How reproducible:
always

Steps to Reproduce:
1. rpmbuild -bp SPECS/qemu.spec
2.
3.
  
Actual results:
Executing(%prep): /bin/sh -e [...]/TMP/rpm-tmp.vWAcvA
+ umask 022
+ cd [...]/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd [...]/BUILD
+ rm -rf qemu-0.9.1
+ /usr/bin/gzip -dc [...]/SOURCES/qemu-0.9.1.tar.gz
+ /bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd qemu-0.9.1
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ echo 'Patch #0 (qemu-0.7.0-build.patch):'
Patch #0 (qemu-0.7.0-build.patch):
+ /bin/cat /home/peb/.fedora/SOURCES/qemu-0.7.0-build.patch
+ /usr/bin/patch -s -p1 --fuzz=0
1 out of 1 hunk FAILED -- saving rejects to file Makefile.target.rej
error: Bad exit status from [...]/TMP/rpm-tmp.vWAcvA (%prep)

RPM build errors:
    Bad exit status from [...]/TMP/rpm-tmp.vWAcvA (%prep)

Expected results:
Well, no build errors.

Additional info:
Haven't yet checked the offending patch (qemu-0.7.0-build.patch).
Comment 1 Bug Zapper 2008-11-25 23:27:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Massimiliano 2009-03-18 14:49:29 EDT
Created attachment 335751 [details]
The log produced by 'mock' command
Comment 3 Massimiliano 2009-03-18 14:50:08 EDT
I have the same problem when I try to rebuild qemu using mock (see the attachment 'build.log') for an i686 platform.

The output from 'uname -mprv':

2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 i686 i686
Comment 4 Mark McLoughlin 2009-03-25 12:55:38 EDT
Thanks for the report

*** This bug has been marked as a duplicate of bug 465041 ***

Note You need to log in before you can comment on or make changes to this bug.