Bug 469115 - X server doesn't start, intel 855GM
X server doesn't start, intel 855GM
Status: CLOSED DUPLICATE of bug 461829
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 19:24 EDT by Lorenzo Pierfederici
Modified: 2008-11-06 11:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 11:23:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (21.25 KB, text/plain)
2008-10-29 19:29 EDT, Lorenzo Pierfederici
no flags Details

  None (edit)
Description Lorenzo Pierfederici 2008-10-29 19:24:48 EDT
Xorg doesn't start and complains about the front buffer:

(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

(I'm attaching the full log for reference)

lspci says my card is:
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

kernel and xorg packages:
kernel-2.6.27.4-58.fc10.i686
xorg-x11-drv-i810-2.5.0-1.fc10.i386
xorg-x11-server-Xorg-1.5.2-10.fc10.i386

(I'm not sure these are the relevant packages, let me know if you need more info about other components!)

BTW, if I boot in graphical mode (or telinit 5 from text mode) I'm stuck in an infinite loop of trying-to-start-xorg->screen-blanking that never fails back to text mode, while in previous version of fedora it used to stop after a few failed tries if there were an error (for example an error in xorg.conf)

I'm setting the severity of this bug to "high" because in my case it has a very high impact on my use of Fedora, but of course feel free to change it to something else if that's not the correct use of "severity"... maybe if it affects just me it's not the severe ;)
Comment 1 Lorenzo Pierfederici 2008-10-29 19:29:29 EDT
Created attachment 321879 [details]
xorg log
Comment 2 Lorenzo Pierfederici 2008-11-05 05:36:45 EST
mhh, the problem is still there in Preview...
Comment 3 Matěj Cepl 2008-11-06 11:23:06 EST

*** This bug has been marked as a duplicate of bug 461829 ***

Note You need to log in before you can comment on or make changes to this bug.