Bug 469140 - Regression: Modify SATA IDE mode quirk missed by ata driver upgrade
Regression: Modify SATA IDE mode quirk missed by ata driver upgrade
Status: CLOSED DUPLICATE of bug 466422
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 00:28 EDT by Wade Mealing
Modified: 2008-10-30 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 19:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch already accepted upstream, was in 5.2 not in 5.3 (12.00 KB, application/octet-stream)
2008-10-30 00:36 EDT, Wade Mealing
no flags Details

  None (edit)
Description Wade Mealing 2008-10-30 00:28:59 EDT
Description of problem:

This bug was copied from
https://bugzilla.redhat.com/show_bug.cgi?id=466422

There is one ahci patch added into RHEL5.2, which is used
to force IDE mode into AHCI mode as ACPI S3 resume.
But RedHat had this patch lost during the upgrade of ata
driver for RHEL5.3.

More information can be found in the bugzilla link: https://bugzilla.redhat.com/show_bug.cgi?id=466422


How reproducible:
Always

Steps to Reproduce:
1. Enter ACPI S3;
2. Do ACPI S3 resume by power button or keyboard

Actual results:
S3 resume failes on some SATA ports.

Expected results:
S3 resume successfully.

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=466422
https://bugzilla.redhat.com/show_bug.cgi?id=432652
Comment 1 Wade Mealing 2008-10-30 00:36:24 EDT
Created attachment 321898 [details]
Patch already accepted upstream, was in 5.2 not in 5.3
Comment 3 Wade Mealing 2008-10-30 19:27:32 EDT

*** This bug has been marked as a duplicate of bug 466422 ***

Note You need to log in before you can comment on or make changes to this bug.