Bug 469157 - [fix available] Openoffice.org crash when opening a particular html file
[fix available] Openoffice.org crash when opening a particular html file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Tardon
desktop-bugs@redhat.com
:
: 469991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 06:52 EDT by Suqin Huang
Modified: 2010-03-30 04:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:45:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message (92.53 KB, image/gif)
2008-10-30 06:52 EDT, Suqin Huang
no flags Details
crash file (308.47 KB, text/html)
2008-10-30 21:48 EDT, Suqin Huang
no flags Details
fix (part 1) (2.41 KB, patch)
2009-08-20 01:41 EDT, David Tardon
no flags Details | Diff
fix (part 2) (2.80 KB, patch)
2009-08-20 01:42 EDT, David Tardon
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 74972 None None None Never
OpenOffice.org 95698 None None None Never

  None (edit)
Description Suqin Huang 2008-10-30 06:52:04 EDT
Created attachment 321913 [details]
Error message

Description of problem:
Openoffice is crashed when open a html file created by terminal.

Version-Release number of selected component (if applicable):
openoffice.org-2.3.0-6.5.4.el5_2

How reproducible:


Steps to Reproduce:
1. Use terminal to create a html file.
2. Open one file by openoffice.
3. Click File->Open to open the html file .
  
Actual results:
Openoffice crash. (The error message is in the attachment) 

Expected results:
The html file is opened successfully.

Additional info:
Comment 1 David Tardon 2008-10-30 09:35:45 EDT
dtardon->shuang: I may be slow in understanding today, but what do you mean by "Use terminal to create a html file"? Could you attach the problematic HTML file? Also, we need text of the crash report, not a screenshot.
Comment 2 Suqin Huang 2008-10-30 21:48:32 EDT
Created attachment 322010 [details]
crash file

1. Open terminal to create a html file. Such as " vim crash.html".
2. Open one website and right click to select "View page source".
3. Copy the source and paste to the html file which is created.

It got a crash during several operation.
The attachment is the example.
Comment 3 Suqin Huang 2008-10-30 23:13:58 EDT
The source copied from TestRunner page will get this crash.
Such as this page "http://batman.bne.redhat.com/bugzilla/tr_showcaselog.cgi?run_id=1269&component_id=21".
Comment 4 David Tardon 2008-10-31 03:29:42 EDT
Confirmed the crash. It crashes on F-9 too; Rawhide is OK.
Comment 5 David Tardon 2008-10-31 03:43:14 EDT
dtardon->shuang: Btw., the assigned HTML file is corrupted. It should start with "<!DOCTYPE", but first four characters are missing, which is probably consequence of copying the HTML page source into editor and saving it from there instead of using Save facility of browser. That corruption has nothing to do with the crash, however.
Comment 6 Suqin Huang 2008-11-04 22:01:15 EST
It also crashes when open a html file which is saved from the website directory.
Steps:
1. Open a website and click "File->Save Page As" to save this page to local mathine. (Can use www.sina.com.cn to have a test)
2. Open this html file with openoffice.openoffice.org-2.3.0-6.10.el5 x86_64 (zh_CN) 	

Additional info:
openoffice.org-2.3.0-6.10.el5 x86_64 (zh_CN) has the same problem
Comment 7 David Tardon 2008-11-05 01:11:16 EST
*** Bug 469991 has been marked as a duplicate of this bug. ***
Comment 8 Caolan McNamara 2009-01-06 11:56:06 EST
caolanm->dtardon: upstream claims to have a fix for this in workspace sw31bf03, can you see if that would also work for 2.3.0 as well ?
Comment 9 David Tardon 2009-01-07 01:03:44 EST
dtardon->caolanm: Yes, I know about it (but thanks anyway). It 'fixes' the original bug--the HTML file gets opened--but it crashes on switch to Print Layout. From quick check in gdb it looks like a problem very similar to the one described on upstream--a frame is moved from inside a nested table--with the difference that frame that is moved outwards is not a SectFrm, but a TxtFrm.

I'm going to look at changes in sw/source/core/layout between 2.3.0 and 3.0.0 .
Comment 13 David Tardon 2009-01-19 06:12:10 EST
dtardon->caolanm: The updated upstream patch solves the problem with switching web<->page layout; at least
Comment 14 David Tardon 2009-01-19 06:14:05 EST
comment 13 was mistake....
Comment 15 David Tardon 2009-05-20 01:03:47 EDT
I've eventually managed to find a solution for this bug. There are two parts of it: the first one is the upstream fix for ooo#95698, the second one increases robustness of code dealing with table model (that has been done in CWS sw8u10bf03 for OOo 2.4.0).
Comment 16 Caolan McNamara 2009-05-20 04:15:32 EDT
sweet
Comment 17 David Tardon 2009-08-20 01:41:31 EDT
Created attachment 358038 [details]
fix (part 1)
Comment 18 David Tardon 2009-08-20 01:42:11 EDT
Created attachment 358039 [details]
fix (part 2)
Comment 20 koka xiong 2009-12-28 04:37:42 EST
Verified with openoffice.org-3.1.1-19.1.el5
on 
Red Hat Enterprise Linux 5Client - i386, x86_64
Red Hat Enterprise Linux 5Server-DPAS - i386, x86_64
1.With the old package,it will crash when open https://bugzilla.redhat.com/attachment.cgi?id=322010
2.With the new package,the open office can open https://bugzilla.redhat.com/attachment.cgi?id=322010 correctly,no crash happens.

Verified passed.
Comment 22 errata-xmlrpc 2010-03-30 04:45:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0274.html

Note You need to log in before you can comment on or make changes to this bug.