This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 469168 - unable to complete boot on kernel-2.6.27.4-58.fc10.x86_64 and beyond
unable to complete boot on kernel-2.6.27.4-58.fc10.x86_64 and beyond
Status: CLOSED DUPLICATE of bug 468856
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-30 08:55 EDT by David Nielsen
Modified: 2008-10-30 23:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 23:58:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2008-10-30 08:55:39 EDT
Description of problem:
Ever since the upgrade to -58 and beyond my machine fails to boot correctly. Plymouth will come up and the progressbar will reach the end but it will never ask for the password to my encrypted partition.

It works with -52 but not beyond (testing up till -68)

This is using x86_64, da_DK.UTF-8 locale, and an ATI card (R6X0 on AGP) with encrypted LVM. Plymouth invoke with vesafb (0x346)

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-[58-58]

How reproducible:
100%

Steps to Reproduce:
1. upgrade to -52+ kernel
2. boot
  
Actual results:
no unlock dialog, endless plymouth bootsplash

Expected results:
smooth boot as with -52

Additional info:
Airlie set on CC.
Comment 1 Brian G. Anderson 2008-10-30 16:08:47 EDT
Me too.  I have a Dell C620 laptop with an encrypted root running an x86_64 kernel.  Nvidia card and US locale.

The bootsplash comes up and shows progress, but never prompts for the volume password.  Interestingly,  in previous kernel if I hit enter in the bootsplash it would drop to text and show me the service loading status lines.  From -58 on I cannot escape out of the bootsplash.
Comment 2 James G. Brown III 2008-10-30 20:09:46 EDT
I have the same issue on both a Dell XPS 400 and IBM x60 both experience the same issue as described although I am running a 32bit kernel. On the IBM I was able to boot to 4-51 kernel successfully. On the Dell I can boot to an earlier kernel although I can't get into X.

- James
Comment 3 James G. Brown III 2008-10-30 21:41:28 EDT
Getting rid of rhgb and quiet from the 2.6.27.4-58 kernel I get the following;

Loading i2c-core module
Loading i2c-algo-bit module
Loading drm module
Loading radeon module
Setting up hotplug
Creating block device nodes.
Making device-mapper control node
Scanning logical volumes
  Reading all physicalvolumes. This may take a while...
Activating logical columes
  Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol01)
Creating root device. 
Mounting root filesystem.
mount: error mounting /dev/root on /sysroot as ext2: No such file or directory
Setting up other filesystems.
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Mount failed for selinuxfs on /selinux: No such file or directory
Switching to new root and running init.
switchroot: mount failed: No such file or directory
Booting has failed.

That's it! Not sure why it's not locating the vg as I can boot successfully to a prior kernels specifically 3-39

- James
Comment 4 Dave Jones 2008-10-30 23:58:07 EDT

*** This bug has been marked as a duplicate of bug 468856 ***

Note You need to log in before you can comment on or make changes to this bug.