Bug 469188 - vfs tapset enhancements
vfs tapset enhancements
Status: CLOSED DUPLICATE of bug 481377
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Frank Ch. Eigler
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 10:34 EDT by William Cohen
Modified: 2009-02-17 12:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 12:29:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2008-10-30 10:34:48 EDT
Description of problem:

It is useful to know what device and inode reads/writes occur on. With systemtap one can follow pointers to find that information. However, that is painful for the typical users to go through the chain of pointers to find the information. There are already functions in the vfs tapset that provide that the device and inode. There are git commits that add those variables to vfs.read, vfs.write, vfs.read.return, and vfs.write.return and adjust the examples to use them:

http://sources.redhat.com/git/gitweb.cgi?p=systemtap.git;a=commit;h=44767f2025faf9cd9fed01ef5d328a2d470dbf1f

http://sources.redhat.com/git/gitweb.cgi?p=systemtap.git;a=commit;h=f2b54492ed30003763833a5a5ac210790af60ec9

http://sources.redhat.com/git/gitweb.cgi?p=systemtap.git;a=commit;h=72dde18184542ab746869bce04869c43f2436217

http://sources.redhat.com/git/gitweb.cgi?p=systemtap.git;a=commit;h=6a1d90ee1b3471847ff11e74bc2cb19928f5de1a
Comment 1 William Cohen 2008-12-03 11:07:36 EST
is this in or out of 5.3? Having this would make the inode-watch example much simpler.
Comment 2 Frank Ch. Eigler 2008-12-03 11:15:16 EST
It's out - was not worth the disruption that a late rebuild could cause.
Comment 3 William Cohen 2009-02-16 16:36:30 EST
Is there going to be a respin of systemtap for 5.4?
Comment 4 Frank Ch. Eigler 2009-02-17 12:29:31 EST

*** This bug has been marked as a duplicate of bug 481377 ***

Note You need to log in before you can comment on or make changes to this bug.