Bug 481377 - systemtap rebase for RHEL5.4
systemtap rebase for RHEL5.4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Frank Ch. Eigler
BaseOS QE
: Rebase
: 469188 (view as bug list)
Depends On:
Blocks: RHEL5u4_relnotes
  Show dependency treegraph
 
Reported: 2009-01-23 15:14 EST by Frank Ch. Eigler
Modified: 2009-09-03 10:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
<para> <filename>SystemTap</filename> is now fully supported, and has been re-based to the latest upstream version. This update features improved user-space probing through shared libraries, experimental DWARF unwinding, and a new <filename>&lt;sys/sdt.h&gt;</filename> header file which provides dtrace-compatible markers. </para> <para> This re-base also enhances support for <filename>debuginfo-less</filename> operations. Typecasting (through the @cast operator) is now supported, along with kernel tracepoint probing. Several <filename>'kprobe.*'</filename> probe bugs that hampered <filename>debuginfo-less</filename> operations are also now resolved. </para> <para> SystemTap also features several documentation improvements. A new '<filename>3stap</filename>' feature provides users with useful man pages on most SystemTap probes and functions. The <filename>systemtap-testsuite</filename> package also features a larger library of sample scripts. </para> <para> For more information about the SystemTap re-base, please refer to the SystemTap section Package Updates chapter of the Technical Notes. </para>
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2009-01-23 15:14:33 EST
Several major features from the community branch of systemtap
would be most conveniently made available to RHEL5 customers
by rebasing rather than backporting many individual pieces.
Comment 2 Frank Ch. Eigler 2009-02-17 12:29:31 EST
*** Bug 469188 has been marked as a duplicate of this bug. ***
Comment 3 Petr Muller 2009-02-18 13:38:48 EST
qe is acking the rebase
Comment 4 Frank Ch. Eigler 2009-04-24 08:42:52 EDT
0.9.7
Comment 6 Frank Ch. Eigler 2009-06-01 14:14:21 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
This version of systemtap includes
- improvements for user-space probing (shared libraries, experimental DWARF unwinding, <sys/sdt.h> instrumentation)
- more support for debuginfo-less operation (@cast operator, kernel tracepoints, kprobe.* probes)
- enlarged sample script library, documentation
- improved script language features, error messages
Comment 8 Don Domingo 2009-06-12 01:27:56 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,5 +1,7 @@
-This version of systemtap includes
+SystemTap is now fully supported, and has been re-based to the latest upstream version. This update features improved user-space probing through shared libraries, experimental DWARF unwinding, and a new <sys/sdt.h> header file which provides dtrace-compatible markers.
-- improvements for user-space probing (shared libraries, experimental DWARF unwinding, <sys/sdt.h> instrumentation)
+
-- more support for debuginfo-less operation (@cast operator, kernel tracepoints, kprobe.* probes)
+This re-base also enhances support for debuginfo-less operations. Typecasting (through the @cast operator) is now supported, along with kernel tracepoint probing. Several 'kprobe.*' probe bugs that hampered debuginfo-less operations are also now resolved.
-- enlarged sample script library, documentation
+
-- improved script language features, error messages+SystemTap also features several documentation improvements. A  new '3stap' feature provides users with useful man pages on most SystemTap probes and functions. The systemtap-testsuite package also features a larger library of sample scripts.
+
+For more information about the SystemTap re-base, please refer to the SystemTap Errata.
Comment 9 Frank Ch. Eigler 2009-07-21 16:00:04 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -4,4 +4,6 @@
 
 SystemTap also features several documentation improvements. A  new '3stap' feature provides users with useful man pages on most SystemTap probes and functions. The systemtap-testsuite package also features a larger library of sample scripts.
 
+To work around bug #499677, please run "rmmod uprobes" as root if the system has not been rebooted since an older version of systemtap had run.
+
 For more information about the SystemTap re-base, please refer to the SystemTap Errata.
Comment 10 Ryan Lerch 2009-07-26 20:41:50 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,9 +1,14 @@
-SystemTap is now fully supported, and has been re-based to the latest upstream version. This update features improved user-space probing through shared libraries, experimental DWARF unwinding, and a new <sys/sdt.h> header file which provides dtrace-compatible markers.
+<para>
+						<filename>SystemTap</filename> is now fully supported, and has been re-based to the latest upstream version. This update features improved user-space probing through shared libraries, experimental DWARF unwinding, and a new <filename>&lt;sys/sdt.h&gt;</filename> header file which provides dtrace-compatible markers.
+					</para>
+<para>
+	This re-base also enhances support for <filename>debuginfo-less</filename> operations. Typecasting (through the @cast operator) is now supported, along with kernel tracepoint probing. Several <filename>'kprobe.*'</filename> probe bugs that hampered <filename>debuginfo-less</filename> operations are also now resolved.
+</para>
 
-This re-base also enhances support for debuginfo-less operations. Typecasting (through the @cast operator) is now supported, along with kernel tracepoint probing. Several 'kprobe.*' probe bugs that hampered debuginfo-less operations are also now resolved.
+<para>
+	SystemTap also features several documentation improvements. A  new '<filename>3stap</filename>' feature provides users with useful man pages on most SystemTap probes and functions. The <filename>systemtap-testsuite</filename> package also features a larger library of sample scripts.
+</para>
 
-SystemTap also features several documentation improvements. A  new '3stap' feature provides users with useful man pages on most SystemTap probes and functions. The systemtap-testsuite package also features a larger library of sample scripts.
+<para>
-
+For more information about the SystemTap re-base, please refer to the SystemTap section Package Updates chapter of the Technical Notes.
-To work around bug #499677, please run "rmmod uprobes" as root if the system has not been rebooted since an older version of systemtap had run.
+					</para>-
-For more information about the SystemTap re-base, please refer to the SystemTap Errata.
Comment 13 errata-xmlrpc 2009-09-02 06:01:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1313.html

Note You need to log in before you can comment on or make changes to this bug.