Bug 469228 - Korganizer Reminder Daemon crashes on boot and cannot be started
Korganizer Reminder Daemon crashes on boot and cannot be started
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 471744 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-30 13:49 EDT by Peter Gückel
Modified: 2009-01-08 01:10 EST (History)
7 users (show)

See Also:
Fixed In Version: 4.1.2-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 16:34:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
korgac.kcrash file (5.70 KB, application/octet-stream)
2008-10-31 19:39 EDT, Peter Gückel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 176566 None None None Never
Novell 450659 None None None Never

  None (edit)
Description Peter Gückel 2008-10-30 13:49:01 EDT
Description of problem:
When the system boots, a message appears, after login, that the korganizer reminder daemon has crashed.

Version-Release number of selected component (if applicable):
kdepim-4.1.2-4.fc10.i386
kdepimlibs-4.1.2-3.fc10.i386
kdepim-libs-4.1.2-4.fc10.i386

How reproducible:
Log in and the daemon will crash.

Steps to Reproduce:
1.Log in
2.Message appears stating daeom crashed
3.
  
Actual results:
Daemon crashes and it is impossible to start it by manually opening korganizer. It never appears in the system tray and reminders don't remind any longer, as they did a couple of days ago.

Expected results:
Reminders remind.

Additional info:
Comment 1 Kevin Kofler 2008-10-30 16:03:07 EDT
Can you please install kdepim-debuginfo and kdepimlibs-debuginfo and gdb and obtain a stack trace? (If the daemon doesn't use KCrash, please run it in gdb to get the backtrace.)
Comment 2 Rex Dieter 2008-10-30 16:21:51 EDT
And if possible, attach your korganizer file(s) in use here (can send privately if you prefer).
Comment 3 Peter Gückel 2008-10-31 13:23:43 EDT
I am installing the required 150MB of debug rpms presently. Upon reboot, I should, hopefully be able to obtain a "stack trace". And Rex, which korganizer files are you referring to?
Comment 4 Rex Dieter 2008-10-31 13:38:47 EDT
~/.kde/share/apps/korganizer/*.ics
Comment 5 Peter Gückel 2008-10-31 19:39:34 EDT
Created attachment 322147 [details]
korgac.kcrash file

This is the backtrace.
Comment 6 Peter Gückel 2008-10-31 19:44:28 EDT
I'm just going to send that for now, as the std.ics has all of my personal information in it. I would have to do extensive editing before I could send it.
Comment 7 Kevin Kofler 2008-10-31 20:37:41 EDT
Hmmm, that's deep in KCal code, looks like fallout from the system libical patch. :-(
I guess we should revert it for F10.

Can you please try downgrading to kdepimlibs-4.1.2-2.fc10 from:
http://koji.fedoraproject.org/koji/buildinfo?buildID=64580
(using rpm -Uvh --oldpackage) and tell us if that fixes it?
Comment 8 Peter Gückel 2008-10-31 22:06:46 EDT
Shall do tout de suite! Then reboot. Be right back.
Comment 9 Peter Gückel 2008-10-31 22:13:39 EDT
kdepimlibs-4.1.2-2.fc10.i386 solved it! Upon login, the reminders of the day appeared, the reminder daemon docked into the systray, and all appears normal once again.

Now I can stop worrying about forgetting one of those birthdays that would be embarassing to forget. Thanks!
Comment 10 Kevin Kofler 2008-10-31 23:15:56 EDT
So I'm now building a 4.1.2-4.fc10 with the change from 4.1.2-3.fc10 (use of the system libical) reverted. That change will need more bugfixing and we don't have the time for f10-final.

You can try 4.1.2-4.fc10 to be sure:
http://koji.fedoraproject.org/koji/buildinfo?buildID=68240
but it should be essentially identical to 4.1.2-2.fc10.
Comment 11 Peter Gückel 2008-10-31 23:42:58 EDT
I updated and rebooted. Daemon is in tray (no reminders triggered at boot, but there aren't any right now) and no crash message. Looks good.
Comment 12 Kevin Kofler 2008-11-15 16:34:06 EST
This has been tagged f10-final long ago.

We still need to fix the underlying libical bug, but at least we have a non-crashing KOrganizer now (even if it uses a private libical). ;-)
Comment 13 Rex Dieter 2008-11-16 07:29:47 EST
*** Bug 471744 has been marked as a duplicate of this bug. ***
Comment 14 Kevin Kofler 2008-12-02 10:48:32 EST
https://bugzilla.novell.com/show_bug.cgi?id=450659#c11 claims there's a fix for it now. We may want to snatch that fix and reenable system libical.
Comment 15 Kevin Kofler 2008-12-02 10:53:29 EST
From the upstream report:
--- Comment #9 from Will Stephenson 2008-12-02 16:51:32 ---
FYI, fixed by backporting r879190 - don't crash when timezone info is NULL.
Comment 16 Kevin Kofler 2009-01-08 01:10:26 EST
FYI, the fix for this has already been backported to 4.1:
http://websvn.kde.org/?view=rev&revision=879229

So we can enable the system libical in the 4.1.4 update.

Note You need to log in before you can comment on or make changes to this bug.