Bug 469346 - X server returns to console with blinking cursor when started
X server returns to console with blinking cursor when started
Status: CLOSED DUPLICATE of bug 446489
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 09:00 EDT by I Fong Lam
Modified: 2008-12-30 15:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-30 15:49:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf generated by X -configure (3.14 KB, text/plain)
2008-10-31 09:01 EDT, I Fong Lam
no flags Details
Xorg.0.log from using xorg.conf.new (68.27 KB, text/plain)
2008-10-31 09:01 EDT, I Fong Lam
no flags Details
xorg.conf.new but with device changed to vesa (3.14 KB, text/plain)
2008-10-31 09:02 EDT, I Fong Lam
no flags Details
Xorg.0.log from using xorg.conf.vesa (68.20 KB, text/plain)
2008-10-31 09:02 EDT, I Fong Lam
no flags Details
xorg.conf using openchrome which works on other Linux distributions (3.71 KB, text/plain)
2008-10-31 09:03 EDT, I Fong Lam
no flags Details
Xorg.0.log from using xorg.conf.openchrome (70.60 KB, text/plain)
2008-10-31 09:04 EDT, I Fong Lam
no flags Details
Xorg.0.log from starting X server without an existing xorg.conf (70.84 KB, text/plain)
2008-10-31 09:04 EDT, I Fong Lam
no flags Details
Output of lspci (1.73 KB, text/plain)
2008-10-31 09:05 EDT, I Fong Lam
no flags Details

  None (edit)
Description I Fong Lam 2008-10-31 09:00:06 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.2) Gecko/2008092418 CentOS/3.0.2-3.el5.centos Firefox/3.0.2

When the X server is starting, the screen turns to black, then returns to the console with a blinking cursor on the top-left corner of the screen.

Reproducible: Always

Steps to Reproduce:
1. Log into root
2. Use startx or X -config
Actual Results:  
When the X server is starting, the screen turns to black, then returns to the console with a blinking cursor on the top-left corner of the screen.

Expected Results:  
A mouse cursor should have appeared in the middle of the screen.

Alt+Fx, Ctrl+Alt+Fx and Ctrl+Alt+Backspace does nothing. I had to reboot using Ctrl+Alt+Delete. The blinking cursor was still there and there wasn't any text being shown, but the system did reboot properly.

Switching the driver from openchrome to vesa produces the same result, so it may not be a problem limited to the openchrome driver. I have also tried a custom xorg.conf which works on other Linux distributions, but to no avail.

I'm installing Fedora 9 onto a HP 2133 Mini-Note. Since there were reports of the LiveCDs not booting into a display, I have installed Fedora using the netinst.iso and updated the packages through the command-line interface before trying to start the X server.

Someone else did manage to get Fedora to work, albeit on Fedora 10 Beta. Here's his report: http://forums.fedoraforum.org/showthread.php?p=1097068#post1097068
Comment 1 I Fong Lam 2008-10-31 09:01:07 EDT
Created attachment 322041 [details]
xorg.conf generated by X -configure
Comment 2 I Fong Lam 2008-10-31 09:01:48 EDT
Created attachment 322042 [details]
Xorg.0.log from using xorg.conf.new
Comment 3 I Fong Lam 2008-10-31 09:02:28 EDT
Created attachment 322043 [details]
xorg.conf.new but with device changed to vesa
Comment 4 I Fong Lam 2008-10-31 09:02:58 EDT
Created attachment 322044 [details]
Xorg.0.log from using xorg.conf.vesa
Comment 5 I Fong Lam 2008-10-31 09:03:32 EDT
Created attachment 322045 [details]
xorg.conf using openchrome which works on other Linux distributions
Comment 6 I Fong Lam 2008-10-31 09:04:14 EDT
Created attachment 322046 [details]
Xorg.0.log from using xorg.conf.openchrome
Comment 7 I Fong Lam 2008-10-31 09:04:47 EDT
Created attachment 322048 [details]
Xorg.0.log from starting X server without an existing xorg.conf
Comment 8 I Fong Lam 2008-10-31 09:05:04 EDT
Created attachment 322049 [details]
Output of lspci
Comment 9 I Fong Lam 2008-11-02 14:36:06 EST
I forgot to say that the openchrome package from the EPEL (http://download.fedora.redhat.com/pub/epel/5/i386/repoview/xorg-x11-drv-openchrome.html) works on CentOS 5.2, if xorg.conf.openchrome is used. Perhaps the build from EPEL has something enabled/disabled which isn't done on the build from Fedora 9?
Comment 10 Xavier Bachelot 2008-11-07 10:58:03 EST
The package for EL-5 is very different than the one in Fedora. First, this is an earlier version of the driver (0.2.901, iirc) but the major difference is elsewhere, EL5 is using xorg xserver 1.4 and this might. Could you please try to rebuild the F9 SRPM on your RHEL5 machine and see if it breaks X or not ?

A workaround to the F9 issue could be to use Option "XaaNoImageWriteRect" or either to switch to EXA acceleration (Option "AccelMethod" "exa"). Can you please give this a try ?
Comment 11 I Fong Lam 2008-11-09 05:41:47 EST
I have built xorg-x11-drv-openchrome-0.2.902-3.fc9.src.rpm on CentOS 5.2 and used xorg.conf.openchrome and it works, with the right resolution.

The only problem is that switching into a virtual console will either turn the screen black or into some white lines on a black screen. I am able to switch back to a GUI though. This inability to switch from an X server to a virtual console seems to pop up in other Linux distributions, so I don't think it's a problem of Fedora.

I have tried both workarounds (both separate and together) on Fedora 9 and it doesn't work.
Comment 12 Xavier Bachelot 2008-12-30 15:49:20 EST

*** This bug has been marked as a duplicate of bug 446489 ***

Note You need to log in before you can comment on or make changes to this bug.