Bug 469504 - Switching from GUI to Console and back causes vertical lines in GUI display
Switching from GUI to Console and back causes vertical lines in GUI display
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
: 485069 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-01 12:58 EDT by Gustav
Modified: 2018-04-11 03:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.2.903-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 19:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf as requested (808 bytes, text/plain)
2008-11-03 19:34 EST, Gustav
no flags Details
Xorg.0.log as requested (66.83 KB, text/plain)
2008-11-03 19:37 EST, Gustav
no flags Details
Xorg.0.log after running without xorg.conf (39.77 KB, text/plain)
2008-11-03 20:42 EST, Gustav
no flags Details

  None (edit)
Description Gustav 2008-11-01 12:58:20 EDT
Description of problem:  If I switch from a GUI to a console using ctrl-alt-fx (where x = 2 thru 6), when I switch back to the GUI using ctrl-alt-f1 the GUI appears with vertical lines spaced equally across the display.  Restarting the X server by logging out (if I was logged in) or executing ctrl-alt-bksp resolves the issue.


Version-Release number of selected component (if applicable):

0.2.903-1-fc10

How reproducible: Every time!

Steps to Reproduce:
1.From GUI logon screen execute ctrl-alt-f2
2.From resulting console execute ctrl-atl-f1 - yields vertical lines in display
3.From GUI logon with vertical lines execute ctrl-alt-bksp - results in clear display
  
Actual results: vertical lines in GUI

Expected results: normal GUI


Additional info: Via CX700M2 chipset
Comment 1 Matěj Cepl 2008-11-03 11:19:57 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Gustav 2008-11-03 19:34:57 EST
Created attachment 322379 [details]
xorg.conf as requested
Comment 3 Gustav 2008-11-03 19:37:58 EST
Created attachment 322380 [details]
Xorg.0.log as requested

There is also an Xorg.0.log.old file in the /var/log/ directory.  Let me know if you would like that as well.
Comment 4 Gustav 2008-11-03 20:42:47 EST
Created attachment 322385 [details]
Xorg.0.log after running without xorg.conf

booted to F10 Live, mounted partition and renamed /etc/X11/xorg.conf to ~.old
booted to HD - resolution reset to 800x600
             - switching to console and back again resulted in vertical lines
reset display to 1280 x 1024 using system-config-display
Xorg.0.log uploaded as requested
Comment 5 Jonathan Kamens 2008-11-13 08:29:29 EST
I see this as well.  What's more, if I then switch to another VT a second time and switch back, the X server doesn't come back at all, and I have to reboot my machine.
Comment 6 Bug Zapper 2008-11-25 23:36:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Xavier Bachelot 2009-01-05 18:27:09 EST
upstream bug : http://www.openchrome.org/trac/ticket/260
Comment 8 Xavier Bachelot 2009-02-11 09:24:56 EST
*** Bug 485069 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2009-02-24 15:54:29 EST
xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2009
Comment 10 Fedora Update System 2009-03-09 19:05:19 EDT
xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.