Bug 469510 - mkinitrd 6.0.68 broke root on LVM on LUKS on raid1
mkinitrd 6.0.68 broke root on LVM on LUKS on raid1
Status: CLOSED DUPLICATE of bug 468856
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-01 15:01 EDT by Alexandre Oliva
Modified: 2008-11-01 15:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 15:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2008-11-01 15:01:38 EDT
Description of problem:
I don't know how many of the $Summary are actually needed to trigger the problem, but the device dependency is clearly broken in 6.0.68.

With the 6.0.67 mkinitrd script (saved before the upgrade, running with 6.0.68 nash and libraries), I get the expected output:

Creating initramfs
Found root device /sys/block/dm-2 for /dev/livre/test
Looking for driver for device /sys/block/dm-2
Looking for driver for device dm-0
Found RAID component md3
Looking for driver for device sda3
Looking for deps of module scsi:t-0x00
Looking for deps of module pci:v000010DEd00000266sv00001558sd00005407bc01sc01i85: sata_nv pata_acpi ata_generic 
Looking for driver for device sdb3
Looking for deps of module scsi:t-0x00
Looking for deps of module usb:v0D49p7000d0200dc00dsc00dp00ic08isc06ip50: usb-storage usb-storage 
Looking for deps of module pci:v000010DEd0000026Esv00001558sd00005407bc0Csc03i20
Looking for driver for device sdc3
Looking for deps of module scsi:t-0x00
Looking for deps of module usb:v152Dp2329d0100dc00dsc00dp00ic08isc06ip50: usb-storage usb-storage 
Looking for deps of module pci:v000010DEd0000026Esv00001558sd00005407bc0Csc03i20
Looking for deps of module scsi:t-0x00
Looking for deps of module usb:v152Dp2329d0100dc00dsc00dp00ic08isc06ip50: usb-storage usb-storage 
Looking for deps of module pci:v000010DEd0000026Esv00001558sd00005407bc0Csc03i20
Found swsusp device /sys/block/dm-1 for /dev/livre/swap

Whereas with the 6.0.68 mkinitrd script, all I get is:

Creating initramfs
Found root device /sys/block/dm-2 for /dev/livre/test
Looking for driver for device /sys/block/dm-2
Looking for driver for device dm-0
Found swsusp device /sys/block/dm-1 for /dev/livre/swap

Note how it fails to find md3, where / is, which makes the system unbootable.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.68

How reproducible:
Every time
Comment 1 Alexandre Oliva 2008-11-01 15:04:10 EDT
Ugh, bugzilla searches ought to search in recently-closed bugs too :-(  Sorry about the noise.

*** This bug has been marked as a duplicate of bug 468856 ***

Note You need to log in before you can comment on or make changes to this bug.