Bug 469559 - cheese doesn't work with Logitech, Inc. QuickCam for DELL Notebooks, ekiga works fine
cheese doesn't work with Logitech, Inc. QuickCam for DELL Notebooks, ekiga wo...
Status: CLOSED DUPLICATE of bug 472217
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 08:34 EST by Thomas J. Baker
Modified: 2008-11-19 08:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 08:24:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cheese log with all debugging turned on (2.57 MB, text/plain)
2008-11-02 08:34 EST, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2008-11-02 08:34:26 EST
Created attachment 322228 [details]
cheese log with all debugging turned on

Cheese stopped working with my uvcvideo webcam sometime since September 16. That was the last time I used it and it worked. I went back to the version of cheese released on September 10 and it doesn't work either so this may be due to kernel driver changes or gstreamer changes. After cheese attempts to open the camera, it leaves it in a state where it doesn't always work again with ekiga. A reboot is then necessary to make the camera work again. I've included a debugging log of running cheese after a reboot so everything is in a consistent state.
Comment 1 Hans de Goede 2008-11-03 04:36:23 EST
If ekiga no longer works after cheese did stuff to the cam, this is most likely a kernel bug. No matter what cheese does, the device should stay working for other apps. It looks to me like cheese rubs the driver the wrong way.

Can you see if "dmesg" contains anything useful like an oops or so ?
Comment 2 Thomas J. Baker 2008-11-14 16:53:10 EST
Sorry, I meant to add this weeks ago. After a fresh reboot, I start cheese and get the following errors under dmesg:

uvcvideo: Failed to query (129) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -75 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).

During the time those messages are being logged, the blue light on the camera comes on for about half a second once (it's on all the time when ekiga is running) and at the end, cheese shows the off the air type video feed that is not from the camera.
Comment 3 Hans de Goede 2008-11-19 08:24:18 EST
This bug is a dup of 472217, please read that bug for more info.

*** This bug has been marked as a duplicate of bug 472217 ***

Note You need to log in before you can comment on or make changes to this bug.