Bug 472217 - Older logitech uvc webcams (spca525 based) stop working in F-10
Older logitech uvc webcams (spca525 based) stop working in F-10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 469559 470667 471949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-19 08:12 EST by Hans de Goede
Modified: 2009-03-15 00:51 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:17:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pic 1 (1.42 KB, image/jpeg)
2009-03-09 13:34 EDT, Edney Matias
no flags Details
Pic 2 (1.55 KB, image/jpeg)
2009-03-09 13:34 EDT, Edney Matias
no flags Details

  None (edit)
Description Hans de Goede 2008-11-19 08:12:09 EST
I've seen various bugs about older logitech uvc webcams (spca525 based) not working in F-10, esp. when used with cheese (gstreamer). So I'm creating this bug to have one place to point all reporters to and to track progress of this issue in one central place.

These cams have a known bug in them which cause the cam to crash sometimes:
http://www.quickcamteam.net/documentation/faq/logitech-webcam-linux-usb-incompatibilities

For a list of all cams with this easy see:
http://www.quickcamteam.net/hcl/linux/logitech_device_list_v2.pdf
All cams in this list which are listed as spca525 have this issue, also see footnote 3 in this document.

Now these cams used to work sometimes / most of the times in F-9, what has changed in F-10 is that cheese does more querying of what the cam can do, and with gstreamer now using libv4l, the amount of queries send to find out device capabilities has increased significantly. And it seems that these cams do not like this large amount of queries at all.

Note this is a known *hardware* bug, so there is not all that much we can do.
Now with that said: currently I'm working on a workaround for this in the UVC driver. I also have plans to make libv4l smarter and cause less queries to be send, but that is something for the longer term.
Comment 1 Hans de Goede 2008-11-19 08:24:18 EST
*** Bug 469559 has been marked as a duplicate of this bug. ***
Comment 2 Hans de Goede 2008-11-19 08:24:26 EST
*** Bug 470667 has been marked as a duplicate of this bug. ***
Comment 3 Hans de Goede 2008-11-19 08:24:30 EST
*** Bug 471949 has been marked as a duplicate of this bug. ***
Comment 4 Hans de Goede 2008-11-19 10:02:28 EST
Ok, I think I have come with a way to fix this, atleast it fixes it on my spca525 based logitech cam, can all original bug reporters please give the kernel which you can download from here a try? :
http://koji.fedoraproject.org/koji/taskinfo?taskID=939908

Thanks!
Comment 5 Benjamín Valero Espinosa 2008-11-19 17:45:40 EST
For my webcam

Bus 001 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam

this kernel doesn't make it work with Cheese. This webcam, after the lists given by you, is not spca525 based, so I don't know if I should open a different bug.
Comment 6 Espen Stefansen 2008-11-19 19:06:02 EST
This did not work with my camera:
Bus 001 Device 007: ID 046d:08c5 Logitech, Inc. QuickCam Pro 5000

I got this in /var/log/messages when starting cheese:
kernel: uvcvideo: Failed to query (130) UVC control 1 (unit 0) : -32 (exp. 26).
kernel: uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -32 (exp. 26).
kernel: uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -32 (exp. 26).
kernel: uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -75 (exp. 26).
kernel: uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
kernel: uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).
kernel: uvcvideo: Failed to query (1) UVC control 1 (unit 0) : -110 (exp. 26).

Another thing I noticed in messages is this, when i connect it:
pulseaudio[2988]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 16000 Hz.
pulseaudio[2988]: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
pulseaudio[2988]: module-alsa-source.c: Your kernel driver is broken: it reports a volume range from 18,00 dB to 18,00 dB which makes no sense.
Comment 7 Thomas J. Baker 2008-11-19 21:56:17 EST
I have this camera:

Bus 001 Device 003: ID 046d:08c6 Logitech, Inc. QuickCam for DELL Notebooks
  idProduct          0x08c6 QuickCam for DELL Notebooks

I usually get messages while running cheese like #6 but didn't get any with this kernel. The blue light even came on on the webcam but I got no video. I then couldn't quit cheese.
Comment 8 Hans de Goede 2008-11-20 05:06:40 EST
(In reply to comment #5)
> For my webcam
> 
> Bus 001 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam
> 
> this kernel doesn't make it work with Cheese. This webcam, after the lists
> given by you, is not spca525 based, so I don't know if I should open a
> different bug.

This is a vc3xxx based cam, not a uvc based one, so yes completelty different issues, does it work in other apps? If it doesn't work anywhere please contact Jean-Francois Moine <moinejf@free.fr>, he maintains the relevant driver. If it does work elsewhere please open a bug against cheese.
Comment 9 Carlo Raudino 2008-11-20 05:27:14 EST
Bus 001 Device 002: ID 046d:09a4 Logitech, Inc.

my webcam is new :S but UVCvideo...and stopped working with f10 as I reported here: https://bugzilla.redhat.com/show_bug.cgi?id=471949
Comment 10 Hans de Goede 2008-11-20 05:43:11 EST
(In reply to comment #9)
> Bus 001 Device 002: ID 046d:09a4 Logitech, Inc.
> 
> my webcam is new :S but UVCvideo...and stopped working with f10 as I reported
> here: https://bugzilla.redhat.com/show_bug.cgi?id=471949

And what happens when you use the new kernel provided here?
Comment 11 Hans de Goede 2008-11-20 05:52:15 EST
(In reply to comment #9)
> Bus 001 Device 002: ID 046d:09a4 Logitech, Inc.
> 
> my webcam is new :S but UVCvideo...and stopped working with f10 as I reported
> here: https://bugzilla.redhat.com/show_bug.cgi?id=471949

Ok, see this one is spca522 based, which is also known to have hardware bugs, see:
http://www.quickcamteam.net/documentation/faq/how-many-versions-of-the-quickcam-pro-9000-are-there

Can you please do:
lsusb -d 046d:09a4 -v | grep bcdDevice
If this prints "0.08", you have a bugged cam.
Comment 12 Hans de Goede 2008-11-20 07:46:34 EST
Ok,

New attempt at fixing this, can you all (except for the person with the zc3xx based cam), please try again with the kernel which you can download here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=940971

(Click on the build for your architecture to get to the files).

Thanks!
Comment 13 Espen Stefansen 2008-11-20 09:02:33 EST
The new kernel didn't work either. :(

Bus 001 Device 007: ID 046d:08c5 Logitech, Inc. QuickCam Pro 5000

From /var/log/messages:
kernel: Linux video capture interface: v2.00
kernel: uvcvideo: Found UVC 1.00 device <unnamed> (046d:08c5)
kernel: uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
kernel: input: UVC Camera (046d:08c5) as /devices/pci0000:00/0000:00:1d.7/usb1/1-3/1-3.3/1-3.3:1.0/input/input6
kernel: usbcore: registered new interface driver uvcvideo
kernel: USB Video Class driver (v0.1.0)
kernel: usbcore: registered new interface driver snd-usb-audio
pulseaudio[2818]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 16000 Hz.
pulseaudio[2818]: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
pulseaudio[2818]: module-alsa-source.c: Your kernel driver is broken: it reports a volume range from 18,00 dB to 18,00 dB which makes no sense.
Comment 14 Paul W. Frields 2008-11-20 09:04:06 EST
Experiencing the same problem, so I tried your kernel-2.6.27.5-122.bz472217.2.fc10.x86_64, which fixes the problem on my Dell XPS M1330, which uses an OmniVision, also a UVC model:

# lsusb output
Bus 002 Device 002: ID 05a9:2640 OmniVision Technologies, Inc.
Comment 15 Thomas J. Baker 2008-11-20 09:12:05 EST
No love with  kernel-2.6.27.5-122.bz472217.2.fc10.x86_64 for me. Same results as before (comment #7) and it seemed to take longer for the pulsating gnome foot to go away and be replaced by just blank white. Let me know if you need further information on the camera itself.
Comment 16 Hans de Goede 2008-11-20 09:16:17 EST
(In reply to comment #14)
> Experiencing the same problem, so I tried your
> kernel-2.6.27.5-122.bz472217.2.fc10.x86_64, which fixes the problem on my Dell
> XPS M1330, which uses an OmniVision, also a UVC model:
> 
> # lsusb output
> Bus 002 Device 002: ID 05a9:2640 OmniVision Technologies, Inc.

!@#$$$$! this is becoming a not so good problem. Paul can you also please try
the kernel from here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=939908

A try, and if that does not work, do:
sudo rmmod uvcvideo
sudo modprobe uvcvideo quirks=64

And try again?
Comment 17 Hans de Goede 2008-11-20 09:18:23 EST
(In reply to comment #15)
> No love with  kernel-2.6.27.5-122.bz472217.2.fc10.x86_64 for me. Same results
> as before (comment #7) and it seemed to take longer for the pulsating gnome
> foot to go away and be replaced by just blank white. Let me know if you need
> further information on the camera itself.

Hmm,

Yes the pulsating feet will take longer with that kernel, that is to be expected.

Can you go to Edit->Preferences and then make sure your cam is selected as input device? And then also try to change the resolution and see if that helps ?
Comment 18 Paul W. Frields 2008-11-20 09:43:40 EST
(In reply to comment #16)
> (In reply to comment #14)
> > Experiencing the same problem, so I tried your
> > kernel-2.6.27.5-122.bz472217.2.fc10.x86_64, which fixes the problem on my Dell
> > XPS M1330, which uses an OmniVision, also a UVC model:
> > 
> > # lsusb output
> > Bus 002 Device 002: ID 05a9:2640 OmniVision Technologies, Inc.
> 
> !@#$$$$! this is becoming a not so good problem. Paul can you also please try
> the kernel from here:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=939908
> 
> A try, and if that does not work, do:
> sudo rmmod uvcvideo
> sudo modprobe uvcvideo quirks=64
> 
> And try again?

I didn't need the "quirks" option.  I used kernel-2.6.27.5-120.bz472217.fc10.x86_64 and that kernel also worked fine for me.
Comment 19 Hans de Goede 2008-11-20 09:51:06 EST
(In reply to comment #18)
> (In reply to comment #16)
> > And try again?
> 
> I didn't need the "quirks" option.  I used
> kernel-2.6.27.5-120.bz472217.fc10.x86_64 and that kernel also worked fine for
> me.

Good, then, as I suspected, you are seeing another bug as this one, which is fixed in that kernel (this one I'm merely trying to work around, as its the hardware thats broken).
Comment 20 Espen Stefansen 2008-11-20 09:52:26 EST
After reading the last comments, I just started cheese and just let it run in the background. A couple of minutes later, it worked! It found all the resolutions. It just took some time finding them. :) It seems I was a bit quick earlier...
Comment 21 darrell pfeifer 2008-11-20 14:02:23 EST
A couple of observations that may be helpful. I also have one of these cameras on a Dell Laptop (sorry, at work right now so no model number). It also worked fine in F9 and until about the last couple of weeks in rawhide.

While both cheese and ekiga have consistently been failing, using the camera via the flash plugin has worked just fine. (I'm guessing flash isn't using gstreamer).

On my camera, the usb device also contains a microphone. The mic is never actually registered, so I'm guessing that the driver is attempting to process/claim the mic rather than ignoring it)

Note that you don't want to upgrade evolution-data-server out of the current koji because it breaks cheese/ekiga which use it.

I haven't tried today's fix yet.
Comment 22 Hans de Goede 2008-11-20 14:14:21 EST
Hi All,

Here is a new version of libv4l, which caches some info and uses that to seriously lower the number if UVC probe commands send to the cam when using gstreamer applications. Please download the RPM's for your arch from here and give them a try:
http://koji.fedoraproject.org/koji/buildinfo?buildID=70394

I'm pretty sure that this fixes things as this lowers the number of UVC probe commands being send to an even lower number then which was the case under F-9.

Please try this with both the first test kernel I did from here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=939908
kernel-2.6.27.5-120.bz472217.fc10

As with an "official" kernel from rawhide / an F-10 snapshot.

I expect this to even fix things with the non patched kernel except for Paul. Paul if your cam does not work in cheese with libv4l-0.5.5 with an official kernel
please file a new bug for that against the kernel, and be sure to CC me.
Comment 23 Espen Stefansen 2008-11-20 15:24:57 EST
With the latest version of libv4l and kernel-2.6.27.5-122.bz472217.fc10, everything works out fine for me. And much quicker than before. Thank you. :)
Comment 24 Hans de Goede 2008-11-20 16:06:53 EST
(In reply to comment #23)
> With the latest version of libv4l and kernel-2.6.27.5-122.bz472217.fc10,
> everything works out fine for me. And much quicker than before. Thank you. :)

Thanks for testing and how does it work with the standard F-10 kernel, iow one installed from rawhide / F-10 beta / snapshot ?
Comment 25 Paul W. Frields 2008-11-20 19:42:19 EST
Hans, my cam did not work with your new libv4l-0.5.5 and the official -117 kernel.  I filed bug 472468 as requested and CC'd you (and mistakenly left an extra comment that should have been here). ;-)  Thanks for your time and patience.
Comment 26 Thomas J. Baker 2008-11-21 08:40:17 EST
The updated libv4l worked for me with a standard kernel.
Comment 27 Espen Stefansen 2008-11-21 19:06:30 EST
My webcam didn't work with kernel-2.6.27.5-120.fc10. Only with kernel-2.6.27.5-122.bz472217.2.fc10.
Comment 28 Hans de Goede 2008-11-22 18:47:58 EST
(In reply to comment #27)
> My webcam didn't work with kernel-2.6.27.5-120.fc10. Only with
> kernel-2.6.27.5-122.bz472217.2.fc10.

Hmm, so even with the new libv4l it does not work with the stock F-10 kernel, interesting, can you please try with the 2.6.27.5-120.bz472217.fc10 kernel available here (my first attempt):
http://koji.fedoraproject.org/koji/taskinfo?taskID=939908

Thanks!

That has a slightly less extreme version of the workaround, this less extreme version is good enough for my cam, so I think / hope it is good enough for your cam too, after which I will submit it upstream.
Comment 29 Fedora Update System 2008-11-24 03:15:58 EST
libv4l-0.5.6-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libv4l-0.5.6-1.fc10
Comment 30 Fedora Update System 2008-11-24 03:16:44 EST
libv4l-0.5.6-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libv4l-0.5.6-1.fc9
Comment 31 Espen Stefansen 2008-11-25 06:48:33 EST
This is the results i got when trying the webcam with libv4l-0.5.6-1.fc10.i386:

kernel-2.6.27.5-117.fc10.i686 -> Not working
kernel-2.6.27.5-120.fc10.i686 -> Not working. But it finds the resolutions, but nothing happens. The screen in cheese is just blank.
kernel-2.6.27.5-120.bz472217.fc10.i686 -> Ok.
kernel-2.6.27.5-122.bz472217.2.fc10.i686 -> Ok.
kernel-2.6.27.5-123.fc10.i686 -> Ok.

In the terminal I got a couple of these while running cheese:
libv4l2: error converting / decoding frame data: v4l-convert: error parsing JPEG header: Bogus jpeg format
Comment 32 Hans de Goede 2008-11-25 07:52:11 EST
(In reply to comment #31)
> This is the results i got when trying the webcam with libv4l-0.5.6-1.fc10.i386:
> 
> kernel-2.6.27.5-117.fc10.i686 -> Not working
> kernel-2.6.27.5-120.fc10.i686 -> Not working. But it finds the resolutions, but
> nothing happens. The screen in cheese is just blank.
> kernel-2.6.27.5-120.bz472217.fc10.i686 -> Ok.
> kernel-2.6.27.5-122.bz472217.2.fc10.i686 -> Ok.
> kernel-2.6.27.5-123.fc10.i686 -> Ok.
> 

Thank very much for the info, that is very helpful!

> In the terminal I got a couple of these while running cheese:
> libv4l2: error converting / decoding frame data: v4l-convert: error parsing
> JPEG header: Bogus jpeg format

Those can be ignored.
Comment 33 Bug Zapper 2008-11-26 00:36:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 34 Fedora Update System 2008-11-26 01:17:36 EST
libv4l-0.5.6-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 Fedora Update System 2008-11-26 01:26:35 EST
libv4l-0.5.6-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 36 Fedora Update System 2008-11-27 21:19:06 EST
kernel-2.6.27.7-130.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kernel-2.6.27.7-130.fc10
Comment 37 Fedora Update System 2008-12-09 06:36:35 EST
kernel-2.6.27.7-134.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 38 Gerard Fernandes 2009-01-19 18:25:52 EST
Machine: Acer TravelMate 4000 (32-bit Centrino Dothan).

Camera: Logitech QuickCam E 3500
Bus 001 Device 004: ID 046d:09a4 Logitech, Inc. 

Kernel: 2.6.27.9-159.fc10.i686

Seems to work erratically with Cheese. Works fine with Ekiga though. Not tested with anything else.

With Cheese, when first started, I can see an image. After some time, the screen goes blank. I have to do something like clicking on the Effects button twice to refresh the screen and then it works again for some time, then stops.

With Ekiga, I can see good image quality, but the quality of image echoed by the echo service is very poor at any res (320x240 or 640x480).
Comment 39 mdeggers 2009-02-24 03:38:42 EST
Machine: Dell 8200 (850 Intel Chipset) 2.0 GHz P4 1.5 GB memory

Bus 002 Device 003: ID 046d:08c5 Logitech, Inc. QuickCam Pro 5000

Kernel: 2.6.27.15-170.2.24.fc10.i686
libv4l-0.5.8-1.fc10.i386

Fails with cheese, kopete
Works with ucview (RGB3)

It's an old machine with an old cam apparently.
Comment 40 Edney Matias 2009-03-09 13:33:37 EDT
By next release you mean F11? 'Cause my cam doesn't work yet or at all! I mean, it kind works but with a lower resolution 160x120 and color are messed. I'm attaching two pics i took today, it's worth than many words. May I reopen this ticket?
Comment 41 Edney Matias 2009-03-09 13:34:16 EDT
Created attachment 334562 [details]
Pic 1
Comment 42 Edney Matias 2009-03-09 13:34:55 EDT
Created attachment 334563 [details]
Pic 2
Comment 43 Hans de Goede 2009-03-09 16:22:12 EDT
(In reply to comment #40)
> By next release you mean F11? 'Cause my cam doesn't work yet or at all! I mean,
> it kind works but with a lower resolution 160x120 and color are messed. I'm
> attaching two pics i took today, it's worth than many words. May I reopen this
> ticket?  

And what would the USB-ID of your cam be, I seriously doubt its spca525 based.
Comment 44 Edney Matias 2009-03-15 00:51:13 EDT
:)

Bus 002 Device 002: ID 05a9:2640 OmniVision Technologies, Inc. OV2640 Webcam

well i'm very very sorry about that, don't know how this bug came to my mail box or maybe i was completely lost. At least i can have my own bug report! Should i delete my pics? :D

Thank you!

Note You need to log in before you can comment on or make changes to this bug.