Bug 469827 - WebKit sub-package gives error dialog
WebKit sub-package gives error dialog
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 05:17 EST by Tim Waugh
Modified: 2009-01-11 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-11 12:49:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2008-11-04 05:17:39 EST
Description of problem:
When starting liferea, an error dialog is displayed:

gcjwebplugin error: Failed to run /usr/lib64/mozilla/plugins/../../bin/pluginappletviewer.  For more detail rerun "firefox -g" in a terminal window.

Firefox works fine on its own with no error dialog.

Version-Release number of selected component (if applicable):
liferea-1.4.20-4.fc9.x86_64
liferea-WebKit-1.4.20-4.fc9.x86_64

How reproducible:
Most of the time (the rest of the time it segfaults on start-up).

Steps to Reproduce:
1.Start liferea
  
Actual results:
Error dialog

Expected results:
No error dialog.

Additional info:
Works fine when liferea-WebKit is not installed.
Comment 1 Tim Waugh 2008-11-04 05:26:12 EST
Output:

libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
Note: WebKit HTML rendering support is experimental and
not everything is working properly with WebKit right now!!!
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
GCJ PLUGIN: thread 0x21ab930: NP_Initialize
GCJ PLUGIN: thread 0x21ab930: plugin_test_appletviewer
gcjwebplugin.cc:1045: thread 0x21ab930: Error: Failed to spawn applet viewer: Failed to execute child process "/usr/lib64/mozilla/plugins/../../bin/pluginappletviewer" (No such file or directory)
GCJ PLUGIN: thread 0x21ab930: plugin_test_appletviewer return
GCJ PLUGIN: thread 0x21ab930: plugin_display_failure_dialog
GCJ PLUGIN: thread 0x21ab930: plugin_display_failure_dialog return
sh: acroread: command not found
Shutting down WebKit

(liferea:16200): Gtk-CRITICAL **: gtk_style_detach: assertion `style->attach_count > 0' failed
Comment 2 Tim Waugh 2008-11-04 05:28:08 EST
Incidentally I *don't* have the WebKit package installed, just liferea-WebKit.
Comment 3 Steven M. Parrish 2008-11-11 16:22:57 EST
WebKit-gtk is a dependency of liferea-WebKit and should be pulled in automatically.  Please check to make sure you have it installed.
Comment 4 Steven M. Parrish 2008-11-11 16:27:08 EST
Also I am unable to reproduce this on any of my systems.  Can anyone else reproduce?
Comment 5 Tim Waugh 2008-11-12 05:06:24 EST
Ah, I do have WebKit-gtk package installed, but not WebKit-qt. (Sorry for confusion.)

Trying this again today, I can only ever get a segfault reported in bug #469831.
Comment 6 Steven M. Parrish 2009-01-11 12:49:21 EST
Going to close this one out,  leaving #469831 open.

Note You need to log in before you can comment on or make changes to this bug.