Bug 469854 - Selecting [Back] then [Next] at Package selection screen clears out all default selected packages
Selecting [Back] then [Next] at Package selection screen clears out all defau...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NEEDSRETESTING
: Reopened
: 470495 (view as bug list)
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-11-04 09:04 EST by James Laska
Modified: 2013-09-02 02:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 18:28:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot failure.jpg (180.71 KB, image/jpeg)
2008-11-04 09:04 EST, James Laska
no flags Details
install.log (81.23 KB, text/plain)
2008-11-04 09:05 EST, James Laska
no flags Details
anaconda.log (33.40 KB, text/plain)
2008-11-04 09:05 EST, James Laska
no flags Details
syslog (50.22 KB, text/plain)
2008-11-04 09:08 EST, James Laska
no flags Details
anaconda-ks.cfg (8.53 KB, text/plain)
2008-11-04 09:10 EST, James Laska
no flags Details
anaconda-logs.tgz (ppc) (13.98 KB, application/x-compressed-tar)
2008-11-04 11:34 EST, James Laska
no flags Details
anaconda-logs.tgz (i386) (29.93 KB, application/octet-stream)
2008-11-06 09:45 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2008-11-04 09:04:59 EST
Created attachment 322426 [details]
Boot failure.jpg

Description of problem:

Manually select *all* package groups.  Somehow selinux is not installed on the system and the system cannot boot after install.

Version-Release number of selected component (if applicable):
anaconda-11.4.1.54

How reproducible:
2/2

Steps to Reproduce:
1. Boot installer
2. Proceed to graphical package selection
3. Manually select every package group (right-side of package selection)
  
Actual results:

EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
type=1404 audit(....): enforcing=1 old_enforcing=0 auid=.... ses=...
SELinux: Could not open policy file <= /etc/selinux/targeted/policy/policy.23: No such file or directory
Unable to load SELinux policy (No such file or directory). Halting now

Expected results:

A boot able system with selinux installed

Additional info:

 * See attached log files
 * See attached boot screenshot
 * Able to boot the system by passing "selinux=0"
Comment 1 James Laska 2008-11-04 09:05:29 EST
Created attachment 322427 [details]
install.log
Comment 2 James Laska 2008-11-04 09:05:50 EST
Created attachment 322428 [details]
anaconda.log
Comment 3 James Laska 2008-11-04 09:08:05 EST
Created attachment 322429 [details]
syslog
Comment 4 James Laska 2008-11-04 09:10:23 EST
Created attachment 322430 [details]
anaconda-ks.cfg

Bingo ... why/how did selinux-policy-targeted get added to the exclude list?

# grep selinux-policy /root/anaconda-ks.cfg 
-selinux-policy-targeted
Comment 5 Daniel Walsh 2008-11-04 10:42:46 EST
If you are running with selinux you need to install a policy, you excluded the policy which causes the machine to not work.
Comment 6 Chris Lumens 2008-11-04 11:05:08 EST
No, the attached anaconda-ks.cfg was the one written out by anaconda after installation.  selinux-policy-targeted is showing up as excluded there because of something anaconda (or hopefully some other package) did.
Comment 7 James Laska 2008-11-04 11:34:24 EST
Created attachment 322446 [details]
anaconda-logs.tgz (ppc)

Same steps followed on ppc F10-PreviewRelease and similar results found ... attaching anaconda-logs-ppc.tgz.

The commonality seems to be that a slew of packages are added to the exclude list somehow.
Comment 8 Chris Lumens 2008-11-05 16:11:45 EST
I remember you previously indicated that if you select all the groups, then hit back, then hit next to return to package selection, all the packages are removed.  Is that what we're seeing here too?
Comment 9 James Laska 2008-11-06 09:45:38 EST
Created attachment 322732 [details]
anaconda-logs.tgz (i386)

Retested now being careful *not* to hit [Back] then [Next] ... it appears to have done the right thing.  selinux is properly installed.

I think it's safe to say this bug is specific to the default||optional package lists being cleared out when going [Back] then [Next] to the pkg selection screen.
Comment 10 Jeremy Katz 2008-11-06 11:14:59 EST
Fixed in git
Comment 11 Chris Lumens 2008-11-07 10:18:47 EST
*** Bug 470495 has been marked as a duplicate of this bug. ***
Comment 12 Jesse Keating 2008-11-07 17:49:29 EST
This will be in rawhide as of 20081108 or later.  Please re-test.
Comment 13 Jesse Keating 2008-11-07 18:28:44 EST
Re-tested with the anaconda just tagged and this is in fact fixed.  Going back, and then going into customize now once again re-sets everything back to their default status.

Note You need to log in before you can comment on or make changes to this bug.