Bug 470495 - no space leads to installer deselecting most packages without intervention
no space leads to installer deselecting most packages without intervention
Status: CLOSED DUPLICATE of bug 469854
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 07:42 EST by David Timms
Modified: 2008-11-07 10:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 10:18:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2008-11-07 07:42:10 EST
Description of problem:
Installer ends up doing a minimal install without yum, X etc.

Version-Release number of selected component (if applicable):
F10 Preview

How reproducible:
Requires / selected to not have enough space to install the chosen packages.

Steps to Reproduce:
1. Trying to use a customize packages later install.
2. Installer notices during preparing transaction that there is not enough disk space [120MB], choose to [go back].
3. Package selection screen is shown.
4. Because the screen takes >15 seconds until it is ready, thought I may not have clicked it properly and clicked the Next button.

Actual results:
1. The screen showed properly for a moment before moving to the next {installer} screen. 
2. Installation preparing transaction begins, completes quickly, and then install of x/300 packages begins.
3. System ends up being a basic text mode boot without yum/X etc.

Expected results:
1. Shouldn't be able to preclick a button (next) before the screen becomes visible.
2. Since installer knows that there is currently more packages selected than will fit, it should require reduction of the package selections before allowing to continue to the begin the install process.
3. Installer should not unselect packages automatically, causing the equiv of basic text mode install.

Additional info:
Occurred on a 3.6G HD on vmware guest, with default package selection.
Comment 1 Chris Lumens 2008-11-07 10:18:47 EST
Your main issue is why I'm duping this bug.  Your secondary issue about the Next button was addressed in another bug.  Both of these should be fixed as of anaconda-11.4.1.56-1.

*** This bug has been marked as a duplicate of bug 469854 ***

Note You need to log in before you can comment on or make changes to this bug.