Bug 470005 - Empathy crashes when connecting to jabber.dk account fails
Empathy crashes when connecting to jabber.dk account fails
Status: CLOSED DUPLICATE of bug 473436
Product: Fedora
Classification: Fedora
Component: loudmouth (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-05 02:58 EST by Tim Lauridsen
Modified: 2008-12-04 07:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 07:50:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash dump when running empathy in a console (6.18 KB, text/plain)
2008-11-05 02:58 EST, Tim Lauridsen
no flags Details
debug output from gabble (12.46 KB, text/plain)
2008-11-08 06:45 EST, Tim Lauridsen
no flags Details

  None (edit)
Description Tim Lauridsen 2008-11-05 02:58:31 EST
Created attachment 322529 [details]
crash dump when running empathy in a console

Description of problem:
Adding my timlau@jabber.dk account and trying to connect.
I get a Network Error in the gui and then Empathy crashes.
If i restart then i see the 'network error' and the gui close down.


Version-Release number of selected component (if applicable):
empathy-2.24.1-1.fc10.i386

How reproducible:
Every time


Steps to Reproduce:
1. start empathy
2. create a new jabber account
3. type 'timlau@jabber.dk' and my password
4. enable the accout
5. connect
  
Actual results:
Gui crashes

Expected results:
Gui should just show the work.


Additional info:
if start 'empathy -n' and add 'jabber.dk' as server in the jabber account then it is working, because then i dont get any 'network error'
so it look like there is 2 issues.
1. the gui is crashing when it cant connect.
2. when i use timlau@jabber.dk as account name, it should use jabber.dk as the server.
Comment 1 Brian Pepple 2008-11-05 11:55:04 EST
Tim, what versions of the telepathy stack do you have on your machine?  In particular I'm interested in the version of tp-gabble since this bug looks similar to a bug we fixed a little while back.

Assigning to F10Target.
Comment 2 Tim Lauridsen 2008-11-06 03:57:20 EST
I not on the current machine at the moment, so i can see the exact version, but the machine is updated against rawhide, every day, so it should contain the latest version available there.

telepathy-gabble.i386                    0.7.12-1.fc10          rawhide

I will check the exact version, later today, when i get home.
Comment 3 Tim Lauridsen 2008-11-07 01:14:44 EST
Here is the versions on the affected system.

Installed Packages
telepathy-filesystem.noarch                    0.0.1-2.fc8             installed
telepathy-gabble.i386                          0.7.12-1.fc10           installed
telepathy-glib.i386                            0.7.17-1.fc10           installed
telepathy-haze.i386                            0.2.1-1.fc10            installed
telepathy-idle.i386                            0.1.2-3.fc9             installed
telepathy-mission-control.i386                 4.67-1.fc10             installed
telepathy-salut.i386                           0.3.5-1.fc10            installed
telepathy-stream-engine.i386                   0.5.3-2.fc10            installed
Comment 4 Brian Pepple 2008-11-07 19:09:08 EST
Hey Tim, could you update tp-gabble to this scratch build (tp-gabble-0.7.13), and see if you still see this bug? https://koji.fedoraproject.org/koji/taskinfo?taskID=921655

If that new version of tp-gabble doesn't fix your bug, could you then run this command in a terminal:

GABBLE_PERSIST=1 LM_DEBUG=net GABBLE_DEBUG=all /usr/libexec/telepathy-gabble 2>&1 | tee gabble.log

and then start up empathy and try to login to your jabber.dk account, and once it fails attach that gabble.log to this bug report.  Thanks.
Comment 5 Tim Lauridsen 2008-11-08 06:45:47 EST
Created attachment 322941 [details]
debug output from gabble
Comment 6 Tim Lauridsen 2008-11-08 06:53:56 EST
The new build don't fix the error.

i have investigated it a little deeper on another just installed machine.
if i just add my timlau@jabber.dk account, without adding jabber.dk as server
i get the network error, but it didn't crash.
But if i add my tim.lauridsen@gmail.com google talk account and i then add the the jabber.dk account, then i get the crash.
Comment 7 Bug Zapper 2008-11-25 23:48:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Brian Pepple 2008-12-03 20:18:34 EST
(In reply to comment #6)
> The new build don't fix the error.
> 
> i have investigated it a little deeper on another just installed machine.
> if i just add my timlau@jabber.dk account, without adding jabber.dk as server
> i get the network error, but it didn't crash.
> But if i add my tim.lauridsen@gmail.com google talk account and i then add the
> the jabber.dk account, then i get the crash.

This should be fixed in loudmouth-1.4.3-1.fc10.  Can you verify that it works for you.  Thanks!

https://admin.fedoraproject.org/updates/F10/FEDORA-2008-10490
Comment 9 Tim Lauridsen 2008-12-04 05:32:50 EST
It is working now, after updating to loudmouth-1.4.3-1.fc10.

THANKS
Comment 10 Brian Pepple 2008-12-04 07:50:54 EST

*** This bug has been marked as a duplicate of bug 473436 ***

Note You need to log in before you can comment on or make changes to this bug.