Bug 473436 - Loudmouth crash when async DNS resolv fails
Loudmouth crash when async DNS resolv fails
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: loudmouth (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Reopened
: 470005 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 09:17 EST by Patrick C. F. Ernzer
Modified: 2008-12-09 23:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 23:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2008-11-28 09:17:22 EST
Description of problem:
Empathy in F10 and rawhide will not connect to a jabber.org account. It gines 'Network error'

Version-Release number of selected component (if applicable):
loudmouth-1.4.3 and 1.4.2

How reproducible:
always

Steps to Reproduce:
1. configure a jabber.org account in Empathy
2. make sure 'Encryption required' is off (different bug)
3. wait for it to connect
  
Actual results:
Network error
looking deeper it's actually
assertion failed in asyncns.c

Expected results:
jabber.com accounts work

Additional info:
upstream has a fix (tested the patch against loudmouth-1.4.3 from rawhide, works for me on 3 machines)
http://loudmouth.lighthouseapp.com/projects/17276-libloudmouth/tickets/33-crash-when-async-dns-resolv-fails
but it's not yet in the upstream tarball as of yesterday

It should be sufficient for you to track the upstream bug and just rebuild for Fedora once the patch is in. It would be extra nice if you could include the patch in the Fedora 10 and rawhide package until upstream has included it.
Comment 1 Fedora Update System 2008-11-28 19:56:41 EST
loudmouth-1.4.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/loudmouth-1.4.3-1.fc10
Comment 2 Patrick C. F. Ernzer 2008-12-01 06:20:52 EST
(In reply to comment #1)
> loudmouth-1.4.3-1.fc10 has been submitted as an update for Fedora 10.

Confirm 1.4.3-1.fc10 fixes the bug. Closing
Comment 3 Brian Pepple 2008-12-01 07:22:47 EST
re-opening, so bodhi can close it when it's pushed to stable
Comment 4 Fedora Update System 2008-12-02 20:10:08 EST
loudmouth-1.4.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update loudmouth'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10490
Comment 5 Brian Pepple 2008-12-04 07:50:54 EST
*** Bug 470005 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2008-12-09 23:36:35 EST
loudmouth-1.4.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.