Bug 470181 - Missing dependency gnome-python2-bonobo
Missing dependency gnome-python2-bonobo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gajim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
: 473339 (view as bug list)
Depends On:
Blocks: 456122
  Show dependency treegraph
 
Reported: 2008-11-06 02:42 EST by Pavel Alexeev
Modified: 2009-05-28 04:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 15:45:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2008-11-06 02:42:37 EST
On Fedora 10 Preview Release gajim failed to start:

$gajim
ImportError: could not import bonobo.ui
Traceback (most recent call last):
  File "gajim.py", line 2279, in <module>
    cli.set_restart_command(len(argv), argv)
AttributeError: '__main__.GnomeClient' object has no attribute 'set_restart_command'


# rpm -q gajim
gajim-0.11.4-4.fc10.i386
Comment 1 John Poelstra 2008-11-06 13:47:33 EST
i'm running the latest gajim-0.11.4-4.fc10.x86_64 package and I do not see this error.

are you running latest updates and can you reproduce this consistently? I'll give a try if I get an i386 rawhide going.
Comment 2 Debarshi Ray 2008-11-07 13:48:07 EST
(In reply to comment #0)

+ Do you have gnome-python2-gnome installed?

+ Can you please run Gajim from the terminal and see if you get a message like this: "Session Management support not available (missing gnome.ui module)" ?
Comment 3 Pavel Alexeev 2008-11-07 15:34:39 EST
(In reply to comment #1)
> i'm running the latest gajim-0.11.4-4.fc10.x86_64 package and I do not see this
> error.
Without installed gnome-python2-bonobo in your system?

> are you running latest updates and can you reproduce this consistently?
Off course. I'm install Fedora 10 PR and have tried several times run gajim.


> + Do you have gnome-python2-gnome installed?
This is qestion to me? s I report initialy if I install package gnome-python2-gnome all works fine, but installation of gajim is not require it in dependencies. And without gnome-python2-gnome gajim fail on start.
Comment 4 Debarshi Ray 2008-11-08 14:31:50 EST
I think the summary should be "Missing dependency gnome-python2-gnome".
Comment 5 Debarshi Ray 2008-11-08 15:45:05 EST
Fixed in gajim-0.11.4-6.
Comment 6 Pavel Alexeev 2008-11-08 16:31:03 EST
You are sure what it should be gnome-python2-gnome? As I remember it is required by gnome-python2-bonobo and was be installed with them. But by initial gajim fail it seems as bonobo required...
Comment 7 Debarshi Ray 2008-11-09 13:48:50 EST
(In reply to comment #6)
> You are sure what it should be gnome-python2-gnome? As I remember it is
> required by gnome-python2-bonobo and was be installed with them. But by initial
> gajim fail it seems as bonobo required...

Can you please reply to comment #2? I find that src/gajim.py needs gnome-python2-gnome and could not locate an import of any bonobo related module.
Comment 8 Pavel Alexeev 2008-11-12 03:16:17 EST
No, gnome-python2-gnome is not enough (even if needed):

# rpm -e gnome-python2-bonobo

# rpm -qa 'gnome-python2*'
gnome-python2-2.22.3-1.fc10.i386
gnome-python2-gnome-2.22.3-1.fc10.i386
gnome-python2-gtkhtml2-2.19.1-23.fc10.i386
gnome-python2-extras-2.19.1-23.fc10.i386
gnome-python2-canvas-2.22.3-1.fc10.i386
gnome-python2-gconf-2.22.3-1.fc10.i386
gnome-python2-gnomevfs-2.22.3-1.fc10.i386


$ gajim
ImportError: could not import bonobo.ui
Traceback (most recent call last):
  File "gajim.py", line 2279, in <module>
    cli.set_restart_command(len(argv), argv)
AttributeError: '__main__.GnomeClient' object has no attribute 'set_restart_command'
Comment 9 Pavel Alexeev 2008-11-12 03:16:17 EST
No, gnome-python2-gnome is not enough (even if needed):

# rpm -e gnome-python2-bonobo

# rpm -qa 'gnome-python2*'
gnome-python2-2.22.3-1.fc10.i386
gnome-python2-gnome-2.22.3-1.fc10.i386
gnome-python2-gtkhtml2-2.19.1-23.fc10.i386
gnome-python2-extras-2.19.1-23.fc10.i386
gnome-python2-canvas-2.22.3-1.fc10.i386
gnome-python2-gconf-2.22.3-1.fc10.i386
gnome-python2-gnomevfs-2.22.3-1.fc10.i386


$ gajim
ImportError: could not import bonobo.ui
Traceback (most recent call last):
  File "gajim.py", line 2279, in <module>
    cli.set_restart_command(len(argv), argv)
AttributeError: '__main__.GnomeClient' object has no attribute 'set_restart_command'
Comment 10 Pavel Alexeev 2008-11-12 03:46:07 EST
Sorry for doubles - bugzilla unstable work today...
Comment 11 Debarshi Ray 2009-05-02 07:56:24 EDT
*** Bug 473339 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2009-05-02 08:09:39 EDT
gajim-0.12.1-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gajim-0.12.1-3.fc9
Comment 13 Fedora Update System 2009-05-02 08:11:02 EDT
gajim-0.12.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gajim-0.12.1-3.fc10
Comment 14 Fedora Update System 2009-05-28 04:00:09 EDT
gajim-0.12.1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-05-28 04:12:11 EDT
gajim-0.12.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.