This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 470182 - Kernel oops during startup
Kernel oops during startup
Status: CLOSED DUPLICATE of bug 467093
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-11-06 03:12 EST by Jiri Pechanec
Modified: 2008-11-06 03:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 03:35:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2008-11-06 03:12:22 EST
Description of problem:
When the XO starts, the kernel generates oops
checking if image is initramfs... it is
------------[ cut here ]------------
WARNING: at arch/x86/mm/pageattr.c:782 change_page_attr_set_clr+0x59/0x193() (Not tainted)
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.27.4-68.fc10.i686 #1
 [<c06c41a7>] ? printk+0xf/0x18
 [<c042bca8>] warn_on_slowpath+0x47/0x70
 [<c04901d1>] ? do_sync_write+0xab/0xe9
 [<c0471580>] ? __free_one_page+0x17a/0x1bf
 [<c041b671>] change_page_attr_set_clr+0x59/0x193
 [<c0474c59>] ? put_page+0x18/0x7d
 [<c048a8c1>] ? virt_to_head_page+0x22/0x2e
 [<c083a02e>] ? unpack_to_rootfs+0x8a8/0x8c9
 [<c041b836>] set_memory_rw+0x11/0x13
 [<c041a4da>] free_init_pages+0x21/0x91
 [<c041a55b>] free_initrd_mem+0x11/0x13
 [<c083a66c>] free_initrd+0x85/0x9f
 [<c083a701>] populate_rootfs+0x7b/0xcd
 [<c0401125>] _stext+0x3d/0x115
 [<c083a686>] ? populate_rootfs+0x0/0xcd
 [<c0464934>] ? register_irq_proc+0x92/0xae
 [<c046498d>] ? init_irq_proc+0x3d/0x4a
 [<c0835362>] kernel_init+0x177/0x1c5
 [<c08351eb>] ? kernel_init+0x0/0x1c5
 [<c04048f7>] kernel_thread_helper+0x7/0x10
 =======================
---[ end trace a7919e7f17c0a725 ]---
Freeing initrd memory: 10623k freed


Version-Release number of selected component (if applicable):
F10 Preview - XO

How reproducible:
Almost every startup

Steps to Reproduce:
Only start the machine and boot to GUI
Comment 1 Alexander Todorov 2008-11-06 03:35:49 EST

*** This bug has been marked as a duplicate of bug 467093 ***

Note You need to log in before you can comment on or make changes to this bug.