Bug 467093 - kernel warning when booting XO
kernel warning when booting XO
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
NEEDSRETESTING
: Reopened
: 470182 470347 (view as bug list)
Depends On:
Blocks: FedoraOnXO F10KernelBlocker
  Show dependency treegraph
 
Reported: 2008-10-15 13:45 EDT by Bryan Kearney
Modified: 2013-01-09 23:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 11:10:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2008-10-15 13:45:52 EDT
Description of problem:

The following kernel.oops shows up with regularity when booting an XO with Snap1.

NET: Registered protocol family 1

checking if image is initramfs... it is

------------[ cut here ]------------

WARNING: at arch/x86/mm/pageattr.c:782 change_page_attr_set_clr+0x5e/0x198() (Not tainted)

Modules linked in:

Pid: 1, comm: swapper Not tainted 2.6.27-1.fc10.i686 #1

 [<c06d8fc3>] ? printk+0x14/0x19

 [<c042d224>] warn_on_slowpath+0x4c/0x7a

 [<c04059cb>] ? mcount_call+0x5/0xa

 [<c04bcd8a>] ? inotify_dentry_parent_queue_event+0xe/0x88

 [<c04059cb>] ? mcount_call+0x5/0xa

 [<c047657d>] ? __free_one_page+0x17f/0x1c4

 [<c041c9c1>] change_page_attr_set_clr+0x5e/0x198

 [<c046cc28>] ? ftrace_record_ip+0x1ac/0x1c5

 [<c046cc28>] ? ftrace_record_ip+0x1ac/0x1c5

 [<c041cbae>] set_memory_rw+0x16/0x18

 [<c041b7d5>] free_init_pages+0x26/0x96

 [<c041b85b>] free_initrd_mem+0x16/0x18

 [<c08507c0>] free_initrd+0x8a/0xa4

 [<c085085a>] populate_rootfs+0x80/0xd2

 [<c040112a>] _stext+0x42/0x11a

 [<c08507da>] ? populate_rootfs+0x0/0xd2

 [<c0467b45>] ? register_irq_proc+0x97/0xb3

 [<c04059cb>] ? mcount_call+0x5/0xa

 [<c0467abc>] ? register_irq_proc+0xe/0xb3

 [<c0467ba3>] ? init_irq_proc+0x42/0x4f

 [<c084b3a8>] kernel_init+0x17c/0x1ca

 [<c084b22c>] ? kernel_init+0x0/0x1ca

 [<c04059b3>] kernel_thread_helper+0x7/0x10

 =======================

---[ end trace a7919e7f17c0a725 ]---

Freeing initrd memory: 10033k freed
Comment 1 Chuck Ebbert 2008-11-01 20:57:40 EDT
arch/x86/mm/pageattr.c:
        /* Ensure we are PAGE_SIZE aligned */
        if (addr & ~PAGE_MASK) {
                addr &= PAGE_MASK;
                /* 
                 * People should not be passing in unaligned addresses: 
                 */
                WARN_ON_ONCE(1);
        }
Comment 2 Jeremy Katz 2008-11-03 11:06:03 EST
Assuming this is on freeing the ramdisk (whichit looks like), it looks like the ramdisk address is page aligned to me.
Comment 3 Alexander Todorov 2008-11-06 03:35:49 EST
*** Bug 470182 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2008-11-06 15:12:48 EST
*** Bug 470347 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2008-11-07 17:02:33 EST
Aha, no it wasn't.

I've updated http://katzj.fedorapeople.org/olpc/livecd-iso-to-disk.sh -- if you try it now, can you confirm that you don't see this warning anymore?  It seems to do the trick for me.
Comment 6 Jesse Keating 2008-11-12 11:23:32 EST
Can somebody please re-test this so that we can confirm the fix?
Comment 7 James Laska 2008-11-12 12:43:53 EST
After several reboots ... not seeing this as of a livecd-creator built image from today.
Comment 8 Jesse Keating 2008-11-12 14:03:41 EST
James, that was using jeremy's livecd-iso-to-disk right?  If so, this needs to be re-opened until a package with that change is tagged.
Comment 9 James Laska 2008-11-12 14:13:02 EST
yeah, I grabbed a livecd-iso-to-disk.sh this morning and built a new Live image this morning.

# md5sum /tmp/livecd-iso-to-disk.sh 
6dc19fe6ed50ea70b7568ba193cdff5a  /tmp/livecd-iso-to-disk.sh

Apologies ... it slipped my mind that the script (http://katzj.fedorapeople.org/olpc/livecd-iso-to-disk.sh) wasn't yet added to livecd-tools.  

Should we re-assign this to livecd-tools?
Comment 10 Jeremy Katz 2008-11-12 14:32:06 EST
Thanks for the verification jlaska.  Pushed changes to the livecd-tools repo and I'm intending to get a release and build of it done tonight (changes are almost entirely livecd-iso-to-disk changes)
Comment 11 Jeremy Katz 2008-11-13 11:10:29 EST
And livecd-tools built

Note You need to log in before you can comment on or make changes to this bug.