Bug 470227 - Unresolvable chain of dependencies with HelixPlayer, RealPlayer, and RealPlayer-uninstall
Unresolvable chain of dependencies with HelixPlayer, RealPlayer, and RealPlay...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: realplayer (Show other bugs)
4.7
All Linux
high Severity high
: rc
: ---
Assigned To: Bastien Nocera
Alexander Todorov
:
: 441778 485188 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 06:57 EST by Radek Bíba
Modified: 2011-02-15 08:58 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date -u output (8.53 KB, text/plain)
2008-11-06 06:57 EST, Radek Bíba
no flags Details

  None (edit)
Description Radek Bíba 2008-11-06 06:57:36 EST
Created attachment 322700 [details]
up2date -u output

Description of problem:
A RHEL 4.7 box with all packages installed hit this error when I tried to update it from RHN. The full up2date output is attached, here's a summary:

 - RHEL 4.7 'everything' installation is performed. It contains HelixPlayer.
 - The box is then subscribed with the Extras channel, which contains RealPlayer
   and RealPlayer-uninstall.
   - RealPlayer obsoletes HelixPlayer.
   - RealPlayer-uninstall obsoletes RealPlayer and HelixPlayer, and conflicts
     with RealPlayer
 - up2date -u is performed
 - transaction fails.

Version-Release number of selected component (if applicable):
up2date-4.7.1-17.el4

Additional info:
This is a showstopper for the update. Looks like one has to uninstall HelixPlayer manually and try up2date -u again. Then it's all right. Another ugly workaround is to do up2date -u RealPlayer, which brings Realplayer and obsoletes HelixPlayer. Then up2date -u is able to update to box, ignoring RealPlayer-uninstall (which is very interesting...).

So, I think up2date is misbehaving. However, feel free to change this to component RealPlayer if its Obsoletes:/Conflicts: are wrong.
Comment 7 Tom G. Christensen 2008-11-26 09:19:00 EST
I'm seeing something in a similar vein here though in my case the chain of dependencies is clear.
A workstation subscribed to the Extras channel with only HelixPlayer installed will see the RealPlayer-uninstall package remove HelixPlayer.

Since there does not seem to be advisory against HelixPlayer this behaviour is unwanted.
Comment 8 John Matthews 2008-12-22 10:01:41 EST
*** Bug 441778 has been marked as a duplicate of this bug. ***
Comment 11 Alexander Todorov 2009-02-10 11:58:10 EST
I'm seeing the same as in comment #7. System is subscribed to the Extras channel and to all BETA channels.
Comment 12 Bastien Nocera 2009-02-12 05:29:16 EST
*** Bug 485188 has been marked as a duplicate of this bug. ***
Comment 15 Alexander Todorov 2009-02-18 07:56:42 EST
I can verify that with RealPlayer-uninstall-10.0.9-4 the update process proceeds without any unsatisfied dependencies.
Comment 22 errata-xmlrpc 2009-05-18 16:28:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1003.html

Note You need to log in before you can comment on or make changes to this bug.