Bug 470286 - Schedd stats graph drawing off right hand side
Schedd stats graph drawing off right hand side
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.1.1
: ---
Assigned To: Justin Ross
Frantisek Reznicek
:
Depends On:
Blocks: 471507
  Show dependency treegraph
 
Reported: 2008-11-06 10:33 EST by Matthew Farrellee
Modified: 2015-11-15 19:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:18:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The moving non-continuous bars (on both graphs). (10.74 KB, image/png)
2008-12-16 05:12 EST, Jan Sarenik
no flags Details

  None (edit)
Description Matthew Farrellee 2008-11-06 10:33:49 EST
cumin r2751

The stats graph for a schedd coming from north-15 is drawing off the right hand side of the graph.

Theory is this is an issue with north-15's clock. However, if true, such an issue would be a nightmare to debug by a customer, so some means to handle clock skew should be implemented.
Comment 1 Ernie 2008-11-10 16:48:51 EST
north-15 was sending stats with a future time (relative to the machine cumin is running on). 

Solution implemented: If the recTime sent in the update message is in the future, use the current time instead.
Comment 3 Jan Sarenik 2008-12-16 05:11:01 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=470315
because of which I can not access any shedulers and see
the graphs on rev 2751.

But nevertheless, I have reproduced the bug on rev 3002:

  0. turn off NTP, set time 20 mins back on local machine
     running cumin (via 'date' command)
  1. clearly install cumin, including database init
  2. log in, add north-15.lab.bos as a broker
  3. Grid -> Schedulers -> <one_scheduler>

Maybe it is not the same as when it continuously started at
(as I understand it) non-visible right-hand side, but the
graphing when the time is not in-sync is definitely strange
in rev 3002. See the attached picture - for at least 5 minutes,
there was no line and suddenly it appeared for the alredy
passed time. And then, when I refreshed the page 5 more minutes
later, the weakly-colored-block moved to right and was not
continuous (still the same length); all repeating. Kind of:

  ------------oooooooooooooooo--|
  --------oooooooooooooooo------|
  ----oooooooooooooooo----------|
  oooooooooooooooo--------------|
  ------------oooooooooooooooo--|
  ... and so on and so forth ...
Comment 4 Jan Sarenik 2008-12-16 05:12:31 EST
Created attachment 327084 [details]
The moving non-continuous bars (on both graphs).

Here is cropped screenshot.
Comment 5 Justin Ross 2008-12-17 11:22:49 EST
I think this is explained by this defect:

The charts only draw segments for data points on the graph.

      10 mins                0 mins
  o   |     o----------o     |
  A         B          C

Since point A is off the end, no A-B segment is drawn.  I think we should try to address this in 1.1.1.
Comment 6 Justin Ross 2009-01-15 15:39:41 EST
Addressed in revision 3046.  I'm querying 1.5 x period seconds, and then bailing out after I get the first sample outside the period window.
Comment 7 Jan Sarenik 2009-01-29 05:13:14 EST
Wonderful! Works as I expect it to.
Verified on RHEL5.3 i386, cumin-0.1.3073-1.el5

  Thanks, Jasan
Comment 8 Jan Sarenik 2009-01-29 05:15:33 EST
I am considering the original time-not-in-sync issue
solved as well and much earlier as there was no off-graph
drawing already in rev 3002.
Comment 10 errata-xmlrpc 2009-04-21 12:18:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.