Bug 471507 - Grid - Default Scheduler statistics update timing
Grid - Default Scheduler statistics update timing
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
1.0
All Linux
medium Severity high
: 1.1.1
: ---
Assigned To: Justin Ross
Frantisek Reznicek
:
Depends On: 470286
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-13 20:20 EST by William Henry
Modified: 2015-11-15 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 14:28:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hour-width graph (14.79 KB, image/png)
2008-12-17 05:22 EST, Jan Sarenik
no flags Details
10minutes-wide graph (42.73 KB, image/png)
2008-12-17 05:22 EST, Jan Sarenik
no flags Details

  None (edit)
Description William Henry 2008-11-13 20:20:56 EST
Description of problem:

Can we examine the timing on the Scheduler statistics page? This page is really important but seems to have a default of 5 minutes. That seems a bit long, no?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Farrellee 2008-11-13 20:43:02 EST
The Scheduler publishes every 5 minutes by default. That does not mean that the graph should only be updated every 5 minute. Watching the line move to the left is disconcerting.

This may be a duplicate of BZ470614
Comment 2 Justin Ross 2008-12-05 10:04:47 EST
I think the chart is just being honest and forthright.  What I think may address this is to make the default timespan for scheduler stats not 10 mins but an hour.
Comment 3 Justin Ross 2008-12-05 17:09:18 EST
I made just such a change at revision 2944.
Comment 5 Jan Sarenik 2008-12-17 05:21:10 EST
Mathew Farellee wrote:
> Watching the line move to the left is disconcerting.

This was not addressed yet - the graph still moves while having
no data, so the line moves to left leaving a blank space meanwhile
there is no update (best visible at '10 minutes' resolution).

See the attachments...
Comment 6 Jan Sarenik 2008-12-17 05:22:08 EST
Created attachment 327219 [details]
hour-width graph
Comment 7 Jan Sarenik 2008-12-17 05:22:45 EST
Created attachment 327220 [details]
10minutes-wide graph
Comment 8 Jan Sarenik 2008-12-18 03:09:20 EST
This bug has a lot to do with 470286, so I recommend pushing it for 1.1.1.
Comment 9 Justin Ross 2009-01-15 14:28:13 EST
I've talked this over with a few people, and I am emboldened my original conclusion.  Drawing the data points you have, and only those, is correct.  It shouldn't be disconcerting that the chart moves to the left: it's displaying all that data it has since the present moment.

The two ways to hide the gap that naturally shows up are both unattractive options:

  1. Add a made-up value, same as the most recent value we have, at zero time.  This creates little disappearing data "plateaus".

  2. Don't update the chart until we get a new sample.  This has the problem of making the time axis a lie, since zero time is no longer approximately now.

Given these options, I prefer things as they are, and I don't think this is a defect.

Note You need to log in before you can comment on or make changes to this bug.